MV Agusta Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5,924 Posts
Discussion Starter #1
I am not getting fuel through 1 of the lines on the bottom of the tank and this seems to be the culprit. If I remove it gas will come out of the opening where it is supposed to go. If it is installed and the tank primes the line remains bone dry.
 

Attachments

·
Registered
Joined
·
28 Posts
Fuel pressure regulator. Im not sure about the bike, but in a car a vacuum hose is attached to the smaller end which opens the valve further as vacuum is increased within the engine. So maybe the vacuum line has become disconnected somewhere or the regulator is faulty. Or possibly nothing to do with that part at all.
 

·
Registered
Joined
·
5,924 Posts
Discussion Starter #3
thanks. There has never been a hose attached even when it was working so. I tried blowing air through it but there is no air flow.
 

·
Registered
Joined
·
28 Posts
It would only flow through the very center hole and the outer holes that ring around the center.

There would never be flow where the vacuum line would go as that is only a diaphragm.

If its blocked a new one should only be $30-$60. Bosch make a lot of FPR's so you can see if it has any markings on it to see what BAR it is and try and get one locally.
 

·
Administrator
Joined
·
19,804 Posts
That is the pressure regulator. On MV the vacuum hose is not attached. It functions on atmospheric pressure at a steady point.
 

·
Super Moderator
Joined
·
22,070 Posts
well I thought it was fixed but it is being starved for fuel
Two questions.
1. Are you sure the tank breather lines to the fuel cap is working as they should ?
2. Did you replace the male and female fittings on your fuel lines ?
 

·
Registered
Joined
·
5,924 Posts
Discussion Starter #9
I checked everything again and it seems one of the lines may have been crimped. running fine now
 
1 - 11 of 11 Posts
Top