MV Agusta Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1
All set to go for a nice ride this weekend in NJ weather was perfect this Saturday morning. Took the bike out of the garage started to move down the driveway and heard a clicking from the back wheel. Then a louder thump and then a grinding sound. From reading posts on the brutale side it looks as if the rear bearing/hub has gone.

1.So I have a few questions, what should I look to replace it with I have seen some people say that the new f4 one is better?
2.How much am I looking at $ wise?
3.Should I sell it and get something new? lol These problems are starting to get on my nerves my brutale is great and messing up perfectly good riding days.
 

·
Administrator
Joined
·
20,060 Posts
Lots of threads on this subject. New hub kit available...from Vesuvio, or from your local dealer in the states.

Chain tension and swing arm pinch bolts are the key to hub life. Disassemble, inspect and lube every 7500 miles....mine were fine at 7500 miles and are still good at 14200.
 

·
Registered
Joined
·
2,496 Posts
Lots of threads on this subject. New hub kit available...from Vesuvio, or from your local dealer in the states.

Chain tension and swing arm pinch bolts are the key to hub life. Disassemble, inspect and lube every 7500 miles....mine were fine at 7500 miles and are still good at 14200.
+1 ....but don't order the hub kit until you've inspected it....it may just be the bearings ($35 maintenance job)
 
1 - 4 of 4 Posts
Top