MV Agusta Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, just got back from Isle of Man TT with my Veloce. Bike was excellent and met some very friendly MV owners.
My only niggle with the bike is that the rear nearside indicator stopped working in March( took delivery Dec 15):violin: . Unfortunately I purchased from Bikers Group who have gone into liquidation. Next nearest dealer is Leicester MV who are kindly doing the indicator under warranty , however I have now been waiting for 2 months and still no sign of replacement. They say they do not know when parts are coming from MV. Poor show on a brand new bike that I otherwise thinks great! Anyone else having similar issues?
Cheers Diggler
 

·
Registered
Joined
·
189 Posts
Hopefully you won't have to wait much longer, as parts are shipping again after several weeks of zero production while the factory financial and ownership wrangles are playing out.
 

·
Registered
Joined
·
1,629 Posts
Whilst there was a hiccough with parts supply a month ago they do seem to be shipping again.

As to the indicator, my TV is in tomorrow having the the very same one replaced (works sporadically) along with the front off side hand-guard assembly (three out of 6 LEDs permanently out), both under warranty. Alerted dealer about this when I had my break-in service done on 22nd of May, they checked parts availability there and then and confirmed the rear one as available and the front one as shortly available. They've had the parts waiting for me to get up there for at least a week now, if not longer.

The indicators do seem to be a weak point, they seem particularly sensitive to water damage. Not great on a sports tourer, especially a premium one like the TV.

Will be asking if I can keep the old parts, though as warranty replacements I think I know the answer to that, so I can investigate and maybe repair to keep as spares and also look at making them more resilient. Conformal coating products spring to mind.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Hi, just got back from Isle of Man TT with my Veloce. Bike was excellent and met some very friendly MV owners.
My only niggle with the bike is that the rear nearside indicator stopped working in March( took delivery Dec 15):violin: . Unfortunately I purchased from Bikers Group who have gone into liquidation. Next nearest dealer is Leicester MV who are kindly doing the indicator under warranty , however I have now been waiting for 2 months and still no sign of replacement. They say they do not know when parts are coming from MV. Poor show on a brand new bike that I otherwise thinks great! Anyone else having similar issues?
Cheers Diggler
Thanks for the info, i'll keep fingers crossed for a phone call.
Derek
 

·
Registered
Joined
·
1,629 Posts
Had both rear left and front right indicators replaced by Jamie, Ed Cosker's tech. Discovered that front left is down to two LED. Not looking good for the future for these components, that's three out of four gone bad in one and a half months. Hopefully the design has been improved internally because continual failure isn't really a realistic proposition. Front left now on order, if it gets here next week Sam, parts and sales, offered to drop in and fit it at my house as he lives fairly local to me, which was nice.

Jamie also ripped out the non functioning MV approved alarm, don't ever consider getting one of these fitted, expensive piece of crap. Coskers will now refuse to fit these, both of the ones they've fitted have failed within a month. Was one hell of a job, lots of panels off and fiddly reaching in to cramped blind spots to disconnect the thing from various parts of the loom.

Another job tackled was the fitting of the new headlamp high beam adaptor. Will post elsewhere, and later, about where and how on the bike to fit this for those who have ordered and intend to self fit. First time they'd done one and with no instructions a voyage of discovery. Thought he'd found the connector to only discover that one side was good but the other didn't fit. At the end he had the nosecone, side panels and tank off to finally discover that the connector he originally found was one end of a similar adaptor which had to be removed and replaced with the new one... At least he'll know how it's done next time. Not a small job, nose cone needs to come off as well as left side panel.

Big thanks to both Jamie and Sam who both stayed late to get this sorted and me happily on my way. Even to the extent that they requested that I take it for a test ride to ensure everything was OK. Refused an attempt to tip them for their duty beyond the call as well. Can't recommend Ed and his staff enough.
 

·
Registered
Joined
·
189 Posts
Not a small job, nose cone needs to come off as well as left side panel.
Cheers, that gives me a clue where to look. Mine arrived this morning. Had a very quick look at the bike and couldn't see anywhere obvious to fit so thought panels would need to come off.
 

·
Registered
Joined
·
445 Posts
I'm still waiting for a left taillight assy for my Rivale. This is the third one that's failed. We'll be at two months very soon.
 
1 - 8 of 8 Posts
Top