MV Agusta Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Has anybody had to replace a turn signal bulb? I went to several auto parts stores, and saw many that would fit that were 10 watt, wedge style halogen.
I got nervous and ended up not purchasing one until i checked with the dealer where i purchased my 2001 750. They told me it was a special bulb, and gave me a part number of: 800093418.
Instead of waiting to find a dealer to order me one, if anyone has replaced a bulb with an aftermarket one, i would really appreciate what you used.

Regards,
Matt
 

·
Registered
Joined
·
2,291 Posts
I just brought the bulb with me to the auto parts store, and had the guy help me find the right one in the book....works out fine.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
well... i found an mv dealer in oregon (closest to me) and will be ordering some oem bulbs. but in the mean time i purchased some cheap bulbs at a local auto parts store.
now the left side blinks extremely SLOW... but at least im legal for now.
i am not that electrically inclined, however i will get it all straightened out shortly.

thanks everyone for the suggestions -
matt
 

·
Registered
Joined
·
878 Posts
Matt, do a search on this... It's been pretty well documented here...it doesn't sound like a bulb problem. It's either indicator relay problem due to after-market parts or contact connection problem. You'll see all the discussions on it after you do a search...

Most issues are pretty well documented on the site, as well as the mvfaq.blogspot.com

Good luck.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Thanks!
I purchased my bike from eastside motorsports in bellevue... I chatted with one of the techs there and he showed me how to loosen up the front fairing and wiggle it for the connections... i had no luck when i tried that - and it looks as if i purchased a 5w bulb instead of a 10w. will do more research from your suggestions and links. very much appreciated!
matt
 
1 - 7 of 7 Posts
Top