MV Agusta Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Just checking... Key in, turned and dash came on as normal etc, no front light and didn't start or even attempt. Put in the charger ad green light blinking softly. This says part 5 is executing. Do I need to wait until
Green light is fixed? Any idea how long the process takes?
 

·
Registered
Joined
·
590 Posts
Yes, wait until the green light is solid. I came home after 5 weeks away and my battery was down to just over 8 volts on the Dragster. I left mine overnight on the trickle charger and fired up no problem the next morning.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
Cheers Jogort!! Just had some doubts as the dash was fine but lights not working. Thought it could be something else.
 

·
Registered
Joined
·
2,213 Posts
Got it!! ����

So you think your battery is flat?
Headlight doesn't come on until the bike is running (I don't think so anyway?) are you sure it's
A. Not in gear
B. Pull clutch in to start
C. Kill switch not pressed in

If your talking about the charger that came with the bike I'm not sure the light/led flashes? I thought it lit up yellow when charging and changed to green when charged.

I always leave my bike plugged into the charger when it's not being used, never had a problem ;)
 

·
Registered
Joined
·
590 Posts
So you think your battery is flat?
Headlight doesn't come on until the bike is running (I don't think so anyway?) are you sure it's
A. Not in gear
B. Pull clutch in to start
C. Kill switch not pressed in

If your talking about the charger that came with the bike I'm not sure the light/led flashes? I thought it lit up yellow when charging and changed to green when charged.

I always leave my bike plugged into the charger when it's not being used, never had a problem ;)
You're right the headlight doesn't come on until the bike is running but the charger that came with the Dragster RR ( I'm assuming it's the same on the Brutale 800RR) only has red/green colours and different flashing speeds to indicate stages of charge.
Could still be a different problem though, as even with my battery low I at least got dash flickering or attempted starter clicking.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #8
Defo in neutral!
Kill switch out.
Clutch pulled as usual.

Yeah, using the charger that came with it after going out to find an adaptor!

Will leave it a few hours and go back and try again.
 

·
Registered
Joined
·
2,213 Posts
Maybe they've changed since the one I got with my Brutale 800 3 yrs ago?

ImageUploadedByMotorcycle1459534333.390507.jpg
 

·
Registered
Joined
·
34 Posts
Discussion Starter #10
Update, rear lights are on, dash is on... All seems perfect!!

Usual starting process I always use but nothing when the button is pressed! Any advice?
 

·
Registered
Joined
·
590 Posts
kill switch? I know, I know but it can get missed. Clutch lever switch or side stand switch maybe causing an issue?
 

·
Registered
Joined
·
590 Posts
Oops, missed previous replies
 

·
Registered
Joined
·
34 Posts
Discussion Starter #13
Ok... So there's a problem. Obviously under warranty but anyone know what happens next? Got a big ride out planned tomorrow. Can't phone the dealer until 9 in the morning. Could've done without this!!
 

·
Registered
Joined
·
34 Posts
Discussion Starter #14
Right, tried bumping it at 10mph in 2nd and 3rd and absolutely nothing. My money is on the wiring to the switch under the clutch. Something is immobilising the bike. Few folks on FB have suggested the side stand switch. What am I looking for?
 

·
Registered
Joined
·
590 Posts
Sorry bud, maybe try n check the voltage of the battery. Could be enough to power everything just enough but without starting. Check fuses for starting circuit also. Don't know if you have the manuals but they're on a sticky post on here from Donsy's site.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #16
Sorry bud, maybe try n check the voltage of the battery. Could be enough to power everything just enough but without starting. Check fuses for starting circuit also. Don't know if you have the manuals but they're on a sticky post on here from Donsy's site.
Cheers, checked all the fuses and they're fine. Got it on charge now overnight. Digging out manuals now. Thanks for your help!
 

·
Registered
Joined
·
590 Posts
I've no looked at the sidestand switch, is the stand light on? I've had the clutch switch off n cleaned up myself, it's a pretty simple switch but worth a try looking at. Get a multimeter on it to make sure it's operating properly.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #18
Spoken to the dealer today, they've said it will Defo be an MV duff battery. They can't get out to collect the bike until mid to late next week!! Currently on the phone to MV Roadside. They're saying they can take it 30 miles! Nearest dealer is 80 miles away. I've asked about them getting someone out to change the battery for me and they're ringing me back but doesn't sound like its something they are going to do!

Would be way cheaper than getting the bike to a dealer 80 miles away!!
 

·
Registered
Joined
·
590 Posts
Sounds about right on the battery side, I've pretty much always got mine on the tender when not in use. Never heard of MV Roadside, is that a UK only thing ?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #20
Sounds about right on the battery side, I've pretty much always got mine on the tender when not in use. Never heard of MV Roadside, is that a UK only thing ?
Never heard of it either!! Dealer gave me the number. They'll only take the bike 30 miles! Useless when nearest dealer is 80 miles away.
 
1 - 20 of 30 Posts
Top