MV Agusta Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Well after the issue i had getting my dragster RR last year (dealership issue with paperwork to get it registered in the UK took 3 months :()

So finally get to the point where i find im due the first service, then to find out the dealership in newcastle (north east UK) has gone bust.. Quick google around and i find my next closest is Thirsk

Thankfully its only an hour away so not so bad, however they got the job done using there last in stock oil filter (with issues with MV they have an issue with parts and had 25 on back order).

All going well till today after a sprited ride home from work i pull onto the drive and it proptly drops its coolant :( and bubbles away, after double checking the overflow bottle after it cooled down i cant see anything in there....

Joys of MV (off to order some coolant now and hope its just gone a bit mad)

Andy

Apart from this minor coolant issue, totally love the bike.
 

·
Registered
Joined
·
590 Posts
Coolant on the Dragster shouldn't be over the min line, mine for the first 8-10,000km was always a little under the min line and hard to see. Never had overheating issues. If it's filled past the min line it'll dump it out.
 

·
Registered
Joined
·
258 Posts
Check your radiator cap. This is a known issue. Mine did the same on my Brutale. The cap has 2 valves. The big spring is on one and that was OK on mine. The centre valve which lets coolant flow back into the radiator was stuck on mine. After a lube up it hasn't been a problem since.
 

·
Registered
Joined
·
33 Posts
Check your radiator cap. This is a known issue. Mine did the same on my Brutale. The cap has 2 valves. The big spring is on one and that was OK on mine. The centre valve which lets coolant flow back into the radiator was stuck on mine. After a lube up it hasn't been a problem since.
What did you lube it with?
 
1 - 6 of 6 Posts
Top