MV Agusta Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
got my new titax shorty clutch lever on the bike today took it a spin and clutch started slipping just about made it home ,changed back to the original one, worked fine a ok, changed back to titax worked fine.i made sure the pinn was put in the little insert right when i fitted the titax the only thing i can think of is i never put the pin right in the insert right and was riding the clutch but just in case anyone else had a pproblem like this ? bikes only done 2300 miles what do you expect to change the clutch at? and need a new set of tyres this also normal for 2300 miles do like to give it the Berry's now and again ha:f4: thanks
 

·
Registered
Joined
·
327 Posts
Hi, i also had this problem with the titax. But i had put the pin into the little insert, Worked for a while then suddenly it started to slip . so what i did was boring the hole in the insert bigger, now the problem is gone. Just a tip if u get the slippery feeling again:) Its not your clutch that im 100% sure of , also the Mv has a wet clutch that means u dont have to worry about changing it for many miles yet.

Although if you keep running the bike with the clutch slipping you can burn up the clutch, and then u have to change it. Hope this helps
 

·
Registered
Joined
·
14,737 Posts
no, unless you are super abusive to the clutch, would you need one in 16k

Noel-theknurl
 

·
Registered
Joined
·
9 Posts
I did have the same problem with the Titax levels. Slipping around 8.000-11.000 revs. First I thought it was the clutch itself. But after reading this topic I shortened the pin about 1-2mm: problem gone.
 

·
Registered
Joined
·
203 Posts
I have Titax on my Brutale (last 12.000 km), and I didn't noticed any sign of slippery clutch jet, but this make me wondering?!?
 
1 - 9 of 9 Posts
Top