MV Agusta Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Everything seems fine but the throttle will not return. (like riding an old Harley with a dead man throttle). This system not covered in the manual. Anyone know where the return spring is? The throttle grip has a lot of friction (hard to turn) so maybe some lube or loosening of its fit?

2004 Brutale

I do have the workshop manual in pdf format. If some one can tell me how to post it, I will.
 

·
Super Moderator
Joined
·
22,472 Posts
Check that the BAR END is not jammed into the throttle tube. There should be a slight gap between the bar end and the throttle grip rubber.
 

·
Registered
Joined
·
1,496 Posts
Throttle cable snapped? or the return spring as come off?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
silentservice703 nailed it. The weather has gotten cold here, 40 F drop since the last ride, must have been enough to change dimensions. Works well now.

How do I post the manual?
 

·
Registered
Joined
·
150 Posts
possibly just need a simple cable lube job
 

·
Registered
Joined
·
1,560 Posts
Mine did that ... water ingress... and a clean and lube fixed it. Usually did it after a ride in the wet!
 

·
Registered
Joined
·
9,955 Posts
Throttle stiff

Everything seems fine but the throttle will not return. (like riding an old Harley with a dead man throttle). This system not covered in the manual. Anyone know where the return spring is? The throttle grip has a lot of friction (hard to turn) so maybe some lube or loosening of its fit?

2004 Brutale

I do have the workshop manual in pdf format. If some one can tell me how to post it, I will.
My friends Brutale throttle has a touch of stiffness.It won't return.

I'm going to try easing off the bar end but it sounds creaky at the nipple end if you'll pardon the expression.

I'm thinking of popping open the handle bar housing and spraying the area with silicon spray..

I don't want to do anything which will attack the cable linings..

joe
 
1 - 8 of 8 Posts
Top