MV Agusta Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter #1
I removed my tank and when I line it up to put the fittings/hoses stuff back on I notice that there is a spigot coming out of the bottom of the tank with nothing to attach. What is supposed to go on this thing? It is a metal piece with the word "Weber" on it and a spigot pointing towards the white fitting. It looks like a hose belongs there, but I can't seem to find any hose that would fit.

I tried searching, but I couldn't really get an idea of what this is.
 

·
Registered
Joined
·
186 Posts
Discussion Starter #2
One more thing, it is a bit late for this, but how do you put the tank on without scratching the FI rails?
 

·
Registered
Joined
·
186 Posts
Discussion Starter #3 (Edited)
BTW, I was getting a 5k rpm rattle (the reason for the tank removal) I found that the little plastic piece on the left side (the one with the CRC sticker on it) was very loose. (Per advice on this board.)
I snugged up all six bolts holding on both sides to the tank. Hopefully that will be enough. If it comes loose again, I will throw some loctite on there and call it good.

I have the bike all back together and ready to go provided that the spigot thing is normally not connected to anything. I distinctly remember only four hoses and the electrical plug. My next step is starting it up and testing it out. :) Rattle be gone! Next up are the mirrors... Got to figure out how to get them to stop rattling.

Took me a bit to figure out the hose routing. First time I put the hoses back on I looked under the tank and the right side overflow hose was kinked by the black clicker fitting. I removed the fittings and put the breather hose on after the fittings.... Much better. :) Black fitting, white fitting, right side overflow, electrical plug, left side overflow. Installed in that order. Looks good now, nothing kinked that I can see.
 

·
Registered
Joined
·
330 Posts
You will never get the Mirrors to stop rattling. That is how they were designed. you know you dont have to pull those two braces off the side of the tank to get it off? Just got to wiggle it around a bit and it will go on.
 

·
Registered
Joined
·
186 Posts
Discussion Starter #6
Yes, I didn't remove the two braces, however, in wiggling around those braces scratch the FI rail. However, you can't see the scratches with all the side panels in place... I guess it is ok.

So it is just a vent... Cool that is what I was thinking, but thought I would make sure. Didn't want my baby to go up in a ball of flame or anything. hehe
 

·
Registered
Joined
·
379 Posts
Hey JamesC,

BTW, many thanks for the fantastic resource that you've put together at MVFAQ. I decided to go with the advice to remove the bracket. Mainly because I'm an OLD hack! My days of taking shortcuts are long gone....
 

·
Registered
Joined
·
186 Posts
Discussion Starter #11 (Edited)
cool, thx for the info

Oh yeah, and the panel was the loud 5k buzz too, now I hear the mirrors, but it is not nearly as loud. I think I can live with the mirrors for a while until I can find some mirrors that I like.

I think I might take it off again and go ahead with the loctite. Is blue ok for that small of a bolt?
 
1 - 12 of 12 Posts
Top