MV Agusta Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,511 Posts
Discussion Starter #1
Jen has reported a fault on her 2015 TV with 4.5k miles clocked. the LHS switchgear has a couple of problems, the horn button is stuck and cannot be depressed, and when switching on the bike at the key the bike starts itself without depressing the starter button!

Anyone else having issues?
 

·
Registered
Joined
·
431 Posts
Not like that jimbo no, I got 4K on mine, couple other issues but I still have to press the button to start and horn is good, I find that my menu select button can sometimes stick to either side and I have to centre it manually. That's the only switchgear problem I'm having.
I'll be giving it a good wash and another thorough coating of acf 50 tomorrow so I'm hoping that cures the sticky menu button.
 

·
Registered
Joined
·
1,511 Posts
Discussion Starter #3
One very grumpy owner is heading for Tim's gaff now, I hope he has a tin hat ready:thewife:
 

·
Registered
Joined
·
1,511 Posts
Discussion Starter #4
Hi,

Switchgear was found to be faulty and replacement was required, took over two weeks to get the part on warranty. All fixed now.
 

·
Registered
Joined
·
4 Posts
I've faced
- Clutch Switch issue(could not crank even though I grab clutch lever, and occurs DSC fault)
I report it on Novemver 2015. But still not fixed till today (My dealer says, MV(Italy) doesn't send part yet. It makes me crazy).
- Self cranking while Key-on (only one time. after that, I've tried several time but it never happens. But it is still make me concern).
- Lean angle sensor malfunction
- Severe oil leak on engine oil cap.
- Clock issue
 

·
Super Moderator
Joined
·
22,072 Posts
I've faced
- Clutch Switch issue(could not crank even though I grab clutch lever, and occurs DSC fault)
I report it on Novemver 2015. But still not fixed till today (My dealer says, MV(Italy) doesn't send part yet. It makes me crazy).
- Self cranking while Key-on (only one time. after that, I've tried several time but it never happens. But it is still make me concern).
- Lean angle sensor malfunction
- Severe oil leak on engine oil cap.
- Clock issue
Is there no way that you could fix even one of these problems yourself if you're desperate ?
 

·
Registered
Joined
·
486 Posts
Dons, now I'm not sayin nitro has or hasn't, but a lot of blokes don't have the inclination, knowledge, courage, let alone tools to work on their own stuff.
And if they don't have these things it's probably best they don't. :)
 

·
Super Moderator
Joined
·
22,072 Posts
I fully understand that Terry, I do. Sometimes though, it's easier than people think it is, with a bit of help a lot can be achieved. And I'm only saying because when I bought my MV I knew very little about working on a bike of the "modern age", but with no dealers around I had to learn some shit very fast, and I'm still learning.
 

·
Registered
Joined
·
445 Posts
I'm on my 4th sprag, second set of tail lights, many map updates to resolve things and my second engine (at 2,400 miles). I do finally have almost 7K miles on it. That's the least I've done in a year on over 30 years. I still think I have the most creative failure. This used to be a clutch BASKET.

 

·
Registered
Joined
·
181 Posts
I'm on my 4th sprag, second set of tail lights, many map updates to resolve things and my second engine (at 2,400 miles). I do finally have almost 7K miles on it. That's the least I've done in a year on over 30 years. I still think I have the most creative failure. This used to be a clutch BASKET.

OK, 2nd engine? What happened to the first? Which model? And what the hell happened to your clutch basket? I'm starting to wonder if I should just sell my Brutale 800.
 

·
Registered
Joined
·
445 Posts
OK, 2nd engine? What happened to the first? Which model? And what the hell happened to your clutch basket? I'm starting to wonder if I should just sell my Brutale 800.
2014 Rivale 800 ABS. Was riding along and it felt like I lost the chain. No loud noises, no odd jerking, just a free revving engine.

MV shipped a new motor immediately. I contacted Helen directly and she sent the 2015 tank and seat with it. No more fuel light at 70 miles.
 

·
Registered
Joined
·
181 Posts
2014 Rivale 800 ABS. Was riding along and it felt like I lost the chain. No loud noises, no odd jerking, just a free revving engine.

MV shipped a new motor immediately. I contacted Helen directly and she sent the 2015 tank and seat with it. No more fuel light at 70 miles.
Under warranty I assume? I'm on my 3rd sprag, 2nd radiator, tip over sensor, 2nd tank etc. And who is Helen? I was dealing with Bruce at MV North America and he and my dealer took care of things. Only problem, I'm out of warranty and running into more problems like the engine running rough and malfunction displays.
 
1 - 13 of 13 Posts
Top