MV Agusta Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
521 Posts
Discussion Starter #1
Hi all :smile2:

I just want to know: has anyone installed this system??
It is to turn off the indicator automatically after a turn or what ever...

I ordered the unit to install my self and the review (youtube) is just great!!
I'm so often forget to turn off the indicator after a round-abound or a turn.. The will help hopefully :grin2:

There are two Version on the marked one for the "normal" bikes and one for the "special" bikes like our TV/TVL
it will cost 149,00€ but at the moment there ist a special winter offer 30% off whit the Code "BATCH33" so just under 100 € !!

here a Video from the Company witch is located in Slovenia ...


and the Address is : http://www.safer-turn.com/

I will put a Installation PDF as well for the system... look at "Aprilia" or "Moto Guzzi" this is the same as the TV /TVL :grin2:

when I receive the unit and installed it , I will come back and will tell about it !!
 

Attachments

·
Registered
Joined
·
909 Posts
Hi Gero HH,

Very interesting...

Just curious:
- is the warning still working?
- where did you mount the module?
- did you have to change connectors or install connectors, or did it come directly with proper connectors installed?
 

·
Registered
Joined
·
521 Posts
Discussion Starter #3
Hi Marc,

the switch works as before R/L press middle to reset.... The indicator light is showing as normal.
The little module you have to mount somewhere in level (behind the side panel or so..)
the module has 4 cables witch has to go in between the cable from indicator switch to the relais.
so you have to cut it... and then of course the + and - :smile2:

in the pdf you can see what I'm talking about...

I will do some pic's when I'm installing the module....
 

·
Registered
Joined
·
909 Posts
the module has 4 cables witch has to go in between the cable from indicator switch to the relais.
so you have to cut it... and then of course the + and - :smile2:

in the pdf you can see what I'm talking about...
Well... I won't cut it. I was hoping it would be something coming with proper wiring, which is not. And if you mess out, you will have to change your wiring harness...
Good luck with that...
 

·
Registered
Joined
·
521 Posts
Discussion Starter #5
You don't have to change the wiring harness at all... you cut the 4 cables and put some male/female Connectors on it.
So you can connect the cables always as it was before!!
The cable what getting cut is the cable from the indicator switch himself. A new switch will have a new cable!!

So not a big deal at all......
 

·
Registered
Joined
·
521 Posts
Discussion Starter #6
receipt the STS Modul yesterday and installed today :smile2:
Installation was easy and quick done. You have to cut 2 wires from the indicator switch (left/right) and connect the module between. Then 12V +- and the reset connection, that's it.

After a test drive I was really impressed!!
It is working like a charm :grin2:
It doesn't matter if it a turn,a overtake, changing lanes or a round abound, it is just working.

Well done piece of electronic
 

Attachments

·
Registered
Joined
·
4 Posts
Hi,
I installed the STS box, the manual is sparse and now my turn signals don't work at all.
Does anyone have the key to which color wires on the STS connect to which color wires on the MVA TVL?

Thanks!
Peter
 
1 - 7 of 7 Posts
Top