MV Agusta Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
Hi guys, took my F3 800 for a ride today. Suddenly dash show me STOP ENG. EXHAUST VALVE. Day before I remove the rear muffler myself just to check how loud it is without the muffler. I put it back again and tight it up all good.

Before the message pop up on my dash, I do feel there is a sudden increase of intake sound, very very loud, but at the same time the bike seems like loss power when I pull the throttle, and next thing this message pop up.

What will be the main reason of this issue? I m thinking of the exhaust butterfly valve couldn't decide when to open and close though...
 

·
Registered
Joined
·
560 Posts
Pretty sure there was a whole issue with the exhaust valves. If I recall correctly there is a recall that replaced the whole head. I know it was done at the port on a number of B3 and F3's when they were entering into the united states. Pretty sure the problem has been remedied from the factory by now.
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #3 ·
Hi Neal, thank you for the info. The error message is not popping up immediately when I start my bike, after somewhile when the bike is warmed up and I pull the throttle hard, the message start to show on the dash. Everytime when I switch of the engine and restart again, the error message will gone and it keep repeating. Guess will need to send my bike to dealer again for them to figure out what's wrong with it...
 

·
Registered
Joined
·
661 Posts
sounds like the exhaust valve is malfunctioning....
 
1 - 4 of 4 Posts
Top