MV Agusta Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi,
My F4RR 312 is pretty new to me. The throttle is smooth but doesn't return on its own.
I literally have to power on and power off with it manually, if i let go, it stays at the same position.
Any ideas if this is normal and if not, how do i have it release on its own?
(it was stood in the rain for a few nights, i think that may have been the cause. Ive tried some WD40 in the edges but it didn't help too much)
ALSO;
compared to my Dragster, the F4 seems to have very little engine braking, is this normal and something I will just get used to?
Thanks
Dom
 

·
Registered
Joined
·
14,500 Posts
?

not normal......

check for kinked/pinched throttle cables

remove the bar end, it may be dragging on the grip

clean/lube the inside of the throttle tube

lube the cables

check that both throttle springs are working


:popcorn:
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thank you!
I removed the bar end and it was too tight, returns faster than i can blink now.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Thank Ian,
It seems the bar end was dragging and loosening it off has released the movement.
If there are any other snags, I'll give the lube a go.
thanks again.
 

·
Registered
Joined
·
1,260 Posts
Rain is the thing that does it, used to happen to my 750 Brutale all the time. Took me four years to work it out! Quick fix is grab the bar end weight and turn it anti clockwise, problem solved at least for a while ;-)
 
1 - 8 of 8 Posts
Top