MV Agusta Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
2,839 Posts
Discussion Starter #1
My screen has squeked since purchase and it has gotten to the point where it's pissing me right off.

I have a tinted aftermarket screen (on there when I purchased the bike and I don't have the origonal) and the squeking's coming form the left hand side (sitting on the bike). If I grab the screen and fairing together or push on the end of the fairing it stops...momentary bliss :highclap: but as soon as I let go :ahhh: :ahhh: :ahhh: .

Anyone know of a cure or something that I can put between the fairing and the screen that wont leave a gap?

:ahhh:
 

·
Registered
Joined
·
2,156 Posts
The easiest way to stop the screen from squeeking (I too use to have the nasty squeek) is to buy yourself velcro which has the peel and stickon glue on bothsides.

You will only be using the velcro which has the felt side and not the curly hook side.

Cut out small pieces of the velcro and stick them between the screen and the fairing. You don't need to place the velcro thoughout the screen. Just experiment and place them in strategic position.

The Velcro compresses easily so you will not see gaps in between the fairing and screen.
Oh I picked up the velcro at a curtain / craft shop cheap and in red as well!!!
 

·
Registered
Joined
·
1,536 Posts
sounds like you have a rodent infestation.
depending on your morals, you can try sevral options from poison to catch and release traps.....stay away from glue traps...the decomposing mouse carcass' start to stink after a while.
 

·
Registered
Joined
·
410 Posts
My screeen squeeks too...I have the MV titanium red replacement screen (looks great...sounds aweful). It was driving me nuts the other day...there's got to be a good fix for it.
 

·
Registered
Joined
·
1,473 Posts
I had the same issue, but on my F4 I determined that it was not the windscreen that was making the noise. My thought was "What could it be rubbing against?" It's connected to the bike via the upper faring, and a bunch of rubber wellnuts. Not often that plastic on plastic makes noise.

Turns out my upper faring was rubbing against the metal headlight bracket and metal plates on either side.

As I stated, I had the issue. It's gone now. Not sure why. I didn't try to fix it. But I have removed my upper faring probably 6-8 times for various reasons and maybe it's now adjusted so that it no longer makes contact against the metal.

Anyway, on my bike it was not the windscreen, but it sure as hell sounded like it was!

Alex
 

·
Registered
Joined
·
339 Posts
On my bike, it was the windscreen. An old riding riding buddy said "Spray a little WD40 on it". I was like well, sounds stupid, but I tried it several months ago and the squeaks went away and haven't returned.
 

·
Registered
Joined
·
1,536 Posts
Nevermore said:
On my bike, it was the windscreen. An old riding riding buddy said "Spray a little WD40 on it". I was like well, sounds stupid, but I tried it several months ago and the squeaks went away and haven't returned.
good tip.
silicone spray lube is often used for automotive weather strip type seals.
 

·
Registered
Joined
·
2,839 Posts
Discussion Starter #12
altoon said:
I had the same issue, but on my F4 I determined that it was not the windscreen that was making the noise. My thought was "What could it be rubbing against?" It's connected to the bike via the upper faring, and a bunch of rubber wellnuts. Not often that plastic on plastic makes noise.

Turns out my upper faring was rubbing against the metal headlight bracket and metal plates on either side.

As I stated, I had the issue. It's gone now. Not sure why. I didn't try to fix it. But I have removed my upper faring probably 6-8 times for various reasons and maybe it's now adjusted so that it no longer makes contact against the metal.

Anyway, on my bike it was not the windscreen, but it sure as hell sounded like it was!

Alex
Good post, the more causes we root out the better. Threre was also a post while back where someone else had a similar issue of the fairing rubbing (squeking) at the front though if I remember correctly I think it was the light itself and they ground off some of the plastic and it fixed the problem.



Mine is also the screen to be sure I removed it the other day and went around the block and there was no squeak. I did put some silicone lube in there in the hope it would reduce friction but I think it actually made it worse.

I'm going to leave work early today to try and fix this and will try either the teflon tape or velcro and I'll let you know asap.
 

·
Registered
Joined
·
1,937 Posts
Rockethouse said:
Threre was also a post while back where someone else had a similar issue of the fairing rubbing (squeking) at the front though if I remember correctly I think it was the light itself and they ground off some of the plastic and it fixed the problem
Yep,

Can be screen, top of headlight to nose fairing, bottom of headlight lens to nose fairing, electrical cover wings to nose fairing and/or air tubes to nose fairing. Most common are top of headlight and screen.
 

·
Registered
Joined
·
200 Posts
never had a squeak until i fitted an aftermarket double buble screen will experiment and put standard one back on
 

·
Registered
Joined
·
2,839 Posts
Discussion Starter #16
Okay, missed out on getting to go for a ride yesterday but I did have a go at fixing the squeak. I purchased some gap seal tape, the spongey stuff that is sticky on one side (I'll post a pic later)....anyway today was about the closest you could want to perfect riding weather and I got to go for a ride.........OMG!!! how sweet it is to not have a that incessant squeak. :)
 
1 - 16 of 16 Posts
Top