MV Agusta Forum banner

1 - 5 of 5 Posts

·
The Dude
Joined
·
5,041 Posts
Discussion Starter #1
Dudes, anybody have any experience with brakes that squeaked and got all vibey through the handle bars on moderate braking in the wet?

I've been caught out in the wet once, didn't notice anything like this. But last night took the brutale out in what I can best describe the English Mist type rain. Just city riding, never getting out of second gear, but coming up to lights I got mad vibes and noise from the front.

The only thing I've done was got Alth Rotors for the front (cuz they look fookin' sweet). I don't believe I changed pads (I'm sure they would have told me, cuz I would have paid for them).

Anybody else get this? Are these fancy rotors only fancy in daytime??


I've got these on there:
http://www.motocorse.jp/02_product/22_alth.html

Here's mine:



thanks,
-colin
 

·
The Dude
Joined
·
5,041 Posts
Discussion Starter #2
shit, this was supposed to be in the brutale section.... um...sorry.... admin, can you move it please?
 

·
Registered
Joined
·
166 Posts
Hi !
You're not the only one !! but this was exclusively during real wet time...
This happen only after changing my mudguard...
was thinking that i didn't fix it back in a proper way ! :naughty:
hope this helps !
 

·
The Dude
Joined
·
5,041 Posts
Discussion Starter #5
fazer6 said:
Sounds like a pad problem, I would check them, or just go ahead and replace them.

Is there some sort of pad that goes with specific rotors? Somebody mentioned if I had changed the pads with the rotors....of course I hadn't.

I had them put on new....
 
1 - 5 of 5 Posts
Top