MV Agusta Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
First off, never posted before but been looking at this site for many years.
I have a 2005 F4 1000 that I got new in 2005, never really had many problems that I couldn't fix but thought I would ask here before tearing into this one.
Battery went dead a few weeks ago so I changed it, bike started fine and I rode it a few miles and put it away.
Yesterday I went to start the bike and it failed.
Turn the key and all dash lights work and go through initial check, side stand light is on (turns off when I put stand up) neutral light is on (turns off when put in gear) cut out switch is set to run.
Push starter and engine cranks but will not start.
Tried with clutch in and side stand up.
Jumped side stand switch and clutch switch.
Checked all the fuses in fuse box.
Opened fuel tank and can hear fuel pump when first turning on ignition.
Any thoughts on what is easy to check?
My problem is I am living in a condo at the moment and only have a parking spot in an underground car park rather than an equipped garage that I am used to.
Thanks for any help.
 

·
Super Moderator
Joined
·
22,311 Posts
This sounds like the infamous hose popping off the fuel pump outlet......
 

·
Vendor
Joined
·
5,330 Posts
I agree with Chuck,when is the last time you changed the internal fuel hoses?Get a torch and have a look inside the tank.Also welcome to the forum and your first post.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
This sounds like the infamous hose popping off the fuel pump outlet......
Thank you very much, just went and had a look and the hose you describe is loose and flapping in the wind, when I turn on the ignition fuel spurts up from the filter.
Also noticed I need to replace all the internal hoses as they seem to be degraded and sticky, probably by that wonderful fuel additive ethanol.
Any special hose I should use when replacing.
 

·
Vendor
Joined
·
5,330 Posts
Submersible fuel injection hose 5/16 diameter and buy some stainless steel hose clamps.I think Chuck (silentservice703) has this hose in bulk.PM him.
 

·
Premium Member
Joined
·
2,879 Posts
If you're in the US and saw the charcoal canister when you looked in there, search for the evap delete thread on here and take it out at the same time.
 

·
Registered
Joined
·
14,489 Posts
?

rblp640hp;
there are 2 types of hose in your fuel tank

the 5/16" submersible high pressure spec J30R10 that goes from the pump to the filter

to the base plate

and the 2 low/no pressure hoses that (stock go to the cannister and pump plate and)

should be wyed together and connected to the drain fitting

check page K02 of the parts manual

you'll need some Clic-R pliers (Ebay ~$ 15)

a fuel filter, grab a WIX 33012 at PepBoys, they have the BEST oil filter too, a Purolator

PL- 14612


:popcorn:
 

·
Super Moderator
Joined
·
22,070 Posts
1 - 8 of 8 Posts
Top