MV Agusta Forum banner
1 - 9 of 9 Posts

Registered
Joined
132 Posts
Discussion Starter · #1 ·
Could someone kindly send me some close up photos of the inside of the front indicators? I think I am missing some screws on the inside of the indicator guards. I want to compare it with someone else's rivale. Sorry for the strange request but I am getting the first rivale in the country and the dealer is not that great. Just to confirm, the screws that you see when looking at the indicator but from the inside of the brake lever. Thanks in advance to who ever send me pics.
 

Registered
Joined
5,146 Posts
Fadel, I can't get a good picture of it with my phone, but if you can circle which screw/hole you are referring to, I can look to see if mine has a screw there.

 

Registered
Joined
132 Posts
Discussion Starter · #3 ·
Thank you Kevin for the quick response.
I can see that top right one is missing on mine.
Are your screws black or silver? The ones that go around the edge of the black casing. There is also one screw that attaches the indicators the the handle bar. Is this black or silver? Mine is black but I don't think it's the original screw because it doesn't seem secure.
 

Registered
Joined
5,146 Posts
Mine are black. I have found a bolt/screw or two on the bike that weren't tight. I've got to get my torque wrench re-calibrated as its 20 years old, but never assume that everything is correct from the factory.
 

Registered
Joined
132 Posts
Discussion Starter · #5 ·
hey Kevin,

i took a photo of the screw i am talking about. i circled it in yellow. this is the screw which seems not secure enough, But i just found out that there was a paper with instructions on how to align the mirrors/indicators which they cant find any more! I looked at the indicators and they don't seem to be aligned properly. I can do it myself but i am trying to find those instructions. Also notice the picture with the cable hanging out. is it supposed to be like that? looks really ugly. how does yours look like? And finally look at the clutch lever, its nearly hitting the inside of the plastic casing of the indicators. That's why I think these mirrors are he not installed properly. Anyone who has these instructions to align the mirrors/indicators would be much appreciated.
 

Attachments

Super Moderator
Joined
24,113 Posts
Fadel, just for what it's worth...Kevin has always had a screw or two loose!
 

Registered
Joined
5,146 Posts
OK Fadel. Here goes.

The screw you circled in yellow is tight on my bike.

The cables that you show hanging loose are wrapped with a 'black rubber band with a button closure' on my bike, so they are not dangling. It appears that the 'black rubber band with a button closure' is wrapped around one of the cables in your picture, so it needs to be un-buttoned and wrapped around both cables after they are tucked/folded into the space in the hand guard.

On my clutch lever, the ball at the end of the lever is 7mm from touching the inside of the hand guard, but cannot be pushed to make contact with it.

Not sure how many of the issues you are seeing are dealer set-up, but you should be able to tighten up screws, and tidy up the cables. And then ride it like you stole it!! :f4:
 

Registered
Joined
5,146 Posts

Registered
Joined
132 Posts
Discussion Starter · #9 ·
Nice one Kevin

I am expecting to pick it up this Saturday. Will let you know how it goes.

BTW. Is it normal to go to the dealers every day to check out the bike? :-|

Iam literally there every day for the past month checking on the bike!

Just wondering if this behaviour is normal!
 
1 - 9 of 9 Posts
Top