MV Agusta Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hi can anyone help my mv agusta dragster 800rr 2015 has a problem .
I thought it was my clutch slipping as the revs were rising, but not accelerating any faster when the bike is in gear. it does this in all gears started off at high revs in higher gears now doing this in all gears from 30mph upwards. I have changed clutch plates but no change, thinking it may be the ride by wire throttle? Any ideas would be great thanks!
 

·
Administrator
Joined
·
19,794 Posts
Engine RPM increases while in gear with clutch lever out, but road speed does not increase????

Only one ting causes that..clutch slipping.

IF that is what you are describing then your clutch needs attention from someone that knows whats what.

Where the heck are you on the planet??? It's not in your profile !!!
 
  • Like
Reactions: theknurl

·
Registered
Joined
·
1,099 Posts
Engine RPM increases while in gear with clutch lever out, but road speed does not increase????

Only one ting causes that..clutch slipping.

IF that is what you are describing then your clutch needs attention from someone that knows whats what.

Where the heck are you on the planet??? It's not in your profile !!!
Have to agree, if the revs are truly rising without an increase in speed, then it's the clutch. You say you replaced the plates, was that the fibres or steels as well?

We have to ask, did you adjust the cable, i recall the drag has a cable not hydraulic clutch. Could it be that you forgot to adjust the lever adjuster or clutch arm adjuster and the clutch is never fully disengaged? easy to check.
 
1 - 3 of 3 Posts
Top