MV Agusta Forum banner

41 - 59 of 59 Posts

·
Registered
Joined
·
7,721 Posts
Discussion Starter #42
Only need a hand full of parts. If only I could get that Carl guy to return my text messages.
 

·
Administrator
Joined
·
19,139 Posts
Only need a hand full of parts. If only I could get that Carl guy to return my text messages.
Send me your list..... He's busy providing ammunition for the masses at the moment.
 

·
Registered
Joined
·
7,721 Posts
Discussion Starter #44
George is helping me out on a few items.

He is what I am needing. Front brake lines which will work with the brembos 4 pad. Clutch switch which goes under the master. Items I can work around is the wires are cut which plug into the clutch and front brake switches. Could use the control units so I can remove the wires from them. The MV logo rubber cap which goes into the headlight housing. The top one, not sure if it is the low or high beam. I will send you some pics to show you what I am talking about.
 

·
Registered
Joined
·
7,721 Posts
Discussion Starter #45
Been working on her the last few nights. Thanks to Ed and Chuck for taking my calls and text messages to get her running. George for sending me some of the parts I needed. I could not get her to run, she was not getting enough fuel. Pulled the injectors out and found that two might be broke. The area where the wires plug into them is loose and one had the wires exposed. So this morning I pulled the injectors out of Mona and placed in the Senna. She started right up. So she ideals fine, took her for a little spin. She likes it when you are on the gas. But not so much when you are at a steady pace. Runs rough. Guess I should add that I also added new plugs in her and that they all have spark to them. Looking for suggestions as to what to check? Could the injectors from Mona be putting out too much gas? For those that don't know Mona has a 1078 engine. Which then can lead to another problem. I am replacing the injectors in Mona with some left over race injectors from fast be ferraci race team.
 

Attachments

·
Registered
Joined
·
166 Posts
The leaves in the driveway are a nice touch!
 

·
Super Moderator
Joined
·
21,780 Posts
Has Drew taken it out yet.....? :smoking:
 

·
Registered
Joined
·
7,721 Posts
Discussion Starter #52
No. With the fueling the way it currently is. I would rather he go out on the Ago when it is in rain mode.
 

·
Registered
Joined
·
850 Posts
Wow great read and lovely bike. I LOVE SENNA and this is so just. Very nice sir, hats off!

Sent from my SM-F900U using Tapatalk
 

·
Registered
Joined
·
231 Posts
Been working on her the last few nights. Thanks to Ed and Chuck for taking my calls and text messages to get her running. George for sending me some of the parts I needed. I could not get her to run, she was not getting enough fuel. Pulled the injectors out and found that two might be broke. The area where the wires plug into them is loose and one had the wires exposed. So this morning I pulled the injectors out of Mona and placed in the Senna. She started right up. So she ideals fine, took her for a little spin. She likes it when you are on the gas. But not so much when you are at a steady pace. Runs rough. Guess I should add that I also added new plugs in her and that they all have spark to them. Looking for suggestions as to what to check? Could the injectors from Mona be putting out too much gas? For those that don't know Mona has a 1078 engine. Which then can lead to another problem. I am replacing the injectors in Mona with some left over race injectors from fast be ferraci race team.
Mate, credit to you for doing all the right things and keeping this beauty alive and kicking. Excellent work!

The calibre of owners on this site is excellent, I've already benefited from lots of good advice and peoples kindness on this forum. Owning an MV is a privilege, being part of this forum is also a privilege. You deserve to own the Senna and she is a credit to you. Glad it's in the right hands now. keep up the good work!
 

·
Registered
Joined
·
2,435 Posts
Andy, did you get the fueling issue resolved? ...would love an update please mate.
 

·
Registered
Joined
·
7,721 Posts
Discussion Starter #58
Andy, did you get the fueling issue resolved? ...would love an update please mate.
I will not be able to use the race injectors on Mona. So I had the ones from the Senna looked at and Cleaned. 2 were bad and had to be replaced. Ordered replacements from the site Knoel suggested. Got them in on Monday and plan on switching the injectors around this weekend.

The race injectors might of been able to work with enough tuning. But Mona would of not idle at the normal and would need to be up around the 2,000 RPM range.
 

·
Registered
Joined
·
2,435 Posts
Have noticed a few of the Gen 1's starting to see clogged injector issues.
Another epic rebuild mate, nicely done.
 
41 - 59 of 59 Posts
Top