MV Agusta Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi Guys

Got my Dragster RR out of the garage today for the first time in a few months and seem to have an issue with the Quickshifter.

Its very difficult to make it work basically - trying to upshift from 1st to 2nd is near on impossible, just won't move. Other gears work coming off the throttle and with a little persuasion.

Downshifts seem to be unaffected.

Any ideas? Is there any adjustment option?

Cheers

Arron
 

·
Super Moderator
Joined
·
22,301 Posts
I would check the settings and ensure you still have the quick shift option engaged.

I would also clean and inspect the quick-shift sensor, wiring and connections for moisture intrusion as others have had issues with this.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Thanks - definitely had the quick shifter mode on and the bike is in Sports Mode so I believe it should work.(and it does intermittently!)

Ill give the clean and inspect a go.
 

·
Registered
Joined
·
1,099 Posts
Hi Guys

Got my Dragster RR out of the garage today for the first time in a few months and seem to have an issue with the Quickshifter.

Its very difficult to make it work basically - trying to upshift from 1st to 2nd is near on impossible, just won't move. Other gears work coming off the throttle and with a little persuasion.

Downshifts seem to be unaffected.

Any ideas? Is there any adjustment option?

Cheers

Arron

If it works in other gears when you come off the throttle, then it's not working. Full throttle shifts should work.

The only way to adjust the QS and Blipper is to flash the ECU. That would also give you access to the diagnostics to see what the ECU is seeing.

The QS is just a resistor network and 2 microswitches. I'd check what voltage is being fed back to the ECU. It's completely possible that only one micro switch is faulty assuming that is the fault, hence blipper still working.

I'd expect the voltage on the bike side of the QS sensor to be at around 2.5 to 2.6v at rest. Then if you pull up and push down the voltage should move up and down by around a volt. I can't remember the wire colour codes off hand, but only 3 wires, approx 5v, 0v and the feed to the ECU.
 
  • Like
Reactions: esq'z me

·
Registered
Joined
·
503 Posts
Hmm, I think this was discussed a few months ago. I also have a Dragster RR. Manual says: don't use the QS from first to second. So, I don't. All other shifts normal.
 

·
Registered
Joined
·
582 Posts
Hmm, I think this was discussed a few months ago. I also have a Dragster RR. Manual says: don't use the QS from first to second. So, I don't. All other shifts normal.
I saw someone else mention this before and thought it was odd. Is this what you are referring to:

".....nor when shifting into lower gears"
 

·
Registered
Joined
·
806 Posts
Hmm, I think this was discussed a few months ago. I also have a Dragster RR. Manual says: don't use the QS from first to second. So, I don't. All other shifts normal.
That had better not say that in my manual for my new Dragster RC, when it arrives (hopefully next Monday) >:)
 

·
Registered
Joined
·
26 Posts
Has anyone swapped out the stock QS for a brand that isn't well...........shite ?

Im about to get mine fired on warranty but i think id sooner pay the extra for something that doesnt have a meltdown everytime it rains.
 

·
Registered
Joined
·
1,099 Posts
I've used a cordona as a replacement for the translogic Durashift.
 
1 - 10 of 10 Posts
Top