MV Agusta Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi fellow F3 lovers :grin2:,

Firstly, I am sorry if I am about to ask something which has already been answered to. I have gone through the threads and have not come across the info I seek.

I love my F3, cannot think of anything better and to make it a bit more fun, I want to install a Quickshifter.

I have the early F3 675 from June 2012 (The manufacturing date) and it is not a version with the EAS. Currently I am in a situation where I can buy the genuine quickshifter from MV for a good price and before I go ahead and do this, I wanted to know from the Gurus if I can equip my bike with it. How to know if it has the necessary hardware for this to work. I can see the options in the Menu for switching on and off the quickshifter but accorrding to the photo I have from the seller, there is a plug which needs to be connected in order for this to function (logical). How do I check if I have the connector on my bike to connect this plug ? Where do I find it and how do I reach it ? A picture would also help for orientation.

Before I go out and shell the money, would be helpful to know this. Thanks guys!!! :wink2:
 

·
Registered
Joined
·
147 Posts
Hi,

This should not be a problem, you should find a 3 pin connector[see pic] behind the lock [left side of the bike] of the rear seat.

The OEM part number is 8A00B6940 [This is the kit WITH appropirate rod] and will cost about 575 ex VAT your best bet from germany might be Star Twin

Foud on ebay:
MV AGUSTA F3 675 quick shifter mv675 quick shifter not the link bar | eBay

Unfortunally this guy seems to sell it without rod if i read this correctly.

Alternativly you could buy the ECU Studio "racing kit" [contains a QS + Software + Hardware] with this kit you will be able to activate the downshift blipper option also, but requires additional ECU Flashing.
More Info: http://www.ecustudio.com/bikes/MV/F3.html#!/
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Hi!,

One of the many reasons I love this community! SO much information.:laugh:
Thanks a tonne for this valuable info and for the fast response. This helps immensely. I was not sure if the 2012 model was capable for a auto blipper. You are right, I would prefer to go for the ECU Studio option. Makes more sense. I have been thinking about using bike for some track days as well but have not mustered the strength for it. In case I put her down, would just pain a lot.
Eventually I if i do go in the track, the ECU Studio gives me a wider customisation.

P.S: Thanks for the tip for Star Trading :)

Happy and safe riding! :smile2:
 

·
Registered
Joined
·
396 Posts
Luerlock if you need additional information just send me a message or send me your number via PM if you prefer talking (in German) about this.
also where in Germany are you located? I already have the ECU Studio solution up and running! so you can potentially save a lot of money there!

if you go for the ECU Studio solution you need to run one additional cable to the plug and disassemble it, otherwise the "new" sensor won't work!
 

·
Registered
Joined
·
291 Posts
I seem to remember a discussion here a while back that the OEM one from MV is made by Starlane....not the greatest.

OP if you're going to be buying your own qs, why not get a better one? HM for example. I'm considering buying an HM myself to add the ability for downshift once I get a race ecu.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
thanks guys ! ! @TastyF3: seems like a pretty sweet deal. The problem could be that he is in the U.S.. I will try to contact him. Good eye that you caught this. @Nepham: Sounds pretty good that there is a working solution you already have. What could be the cost of the whole system (the website mentions around 600 Euros). I will be PMing you with my details.

I plan to go to my garage after my work to have a look at my bike. Like seen in this picture above posted by RCEE, I do not remember seeing such a connector ever, just hanging around on my bike, this is why I am not sure if the very initial f3 675s had the option to connect the quickshifter. Here is hoping that i find one.. :smile2:
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
I seem to remember a discussion here a while back that the OEM one from MV is made by Starlane....not the greatest.

OP if you're going to be buying your own qs, why not get a better one? HM for example. I'm considering buying an HM myself to add the ability for downshift once I get a race ecu.
So how i understand, for the ability to have downshifting one must have a race ECU installed ? :surprise: But that must cost extra I guess..
 

·
Registered
Joined
·
396 Posts
@Luerlock check behind the frame, all F3's should have this connector, maybe hidden behind the frame by a rubber or so but it should be there!

the price depends a bit. Do you just want a "one-time-flash" with no other things done? You can send me your ECU then or ride to me and we do the flash together so you don't have to buy the cable and stuff.
other than the license you just need to have your bike prepared (sensor and wiring loom prepared), the license for ECU studio and you are good to go!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
So guys! Good news -- I did find the connector behind the bike's frame like @Nephalem and @RCEE mentioned it. It was very well hidden with a Rubber cap on top. Had it not been for the picture from @RCEE, I would have not found it. Like @Spark mentioned, the connector had 3 pins which I assume correspond to 3 wires.

You were all awesome.. Thanks.. Will keep you guys updated of what comes next. I eventually also need to replace the radiator hose since I discovered a while ago that it leaks and trying to fix it was not very successful.. :|
 

·
Registered
Joined
·
396 Posts
good thing you found it!

3 wires unfortunately doesn't automatically mean you can run the blipper! one of the cables (Pin1) needs to be a purple one in order for that to work on the "older" bikes, MV changed the wiring loom when they introduced the EAS 2.0 system

if Pin1 has any other colour the EAS 2.0 sensor (or any other 2-way-sensor) will NOT work until you do that modification!
 

·
Registered
Joined
·
44 Posts
I have Up & Down shifting now.

After 1.5 years of owning a TLV and loving the ease of 2.0 shifting, I had to get it on my F3 800.
My F3 came with 1.0 (up only), and not to mention the stock sensor is CRAP. I had it replaced due to intermittent failure.

Now my F3 is out of warranty I decided to go with the aftermarket auto-blip route with trans logic sensor. Get into the ECU(using ecu studio) make the necessary changes, run a wire from TO sensor to the new QS. WOW, I love it. Plus I can make changes to mapping. I will need to learn a lot before I do, but track season is over. I have until next spring when track days open up again.
 

·
Registered
Joined
·
18 Posts
Hello fellow MV nuts,

I have just bought a QS from one of our members here, for my 2012 B3.
Trying to install it is proving to be a mission as for the life of me I can not find the 3 pin connector.
The tank is off, the battery and battery box is out.

The member I bought it off says to make a connector??

Tomorrow I will take off the airbox and search further, but in the meantime does anyone know the pinouts to make my own cable.

Thanks in anticipation....
 

·
Registered
Joined
·
2 Posts
Hi,

im also new here as i own my Brutale 675 (2012) since last week.

The Brutale is not equipped with an Quickshiftsensor and i also have issues with finding the plug to upgrade it.

Does anyone has a solution for that?

Thanks in advance.
 

·
Registered
Joined
·
1,067 Posts
the connector, if you have one on your wiring loom should be tucked above the Gear selector shaft.

Given the age of your bike, its possible that the loom does not have the connector. Ask Aaron or Luca at ECU Studio ([email protected]) if they know whether you can add the wire to the ECU for the QS to work. The power and ground wires are simple. Just whether the ECU has the wire connected or not.
 

·
Registered
Joined
·
2 Posts
Thanks for your Feedback.
i allready check on the ECU connector and I saw that the PIN for the Quickshifter is empty. So i ordered the cables and plugs to upgrade the wiring for the Blipper... I hope it will work.
 
1 - 19 of 19 Posts
Top