MV Agusta Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
Hi gang,

I thought I would throw up, so let me irritate some,

When you rip off your swing arm everything is okay as you lever it away from their mounts, but when you put it back on, make sure you loosen the lower engine mounts or you

Be filing the frame burring after you realized it wont fit if you don't, same with the upper rear shock swivel linkage system,

Once that was sorted I scratched the rear rim a bit changing my tyre, [psst that's how its spel't down ear] now that ain't so bad cause it will make it lighter see

Any hoo, she wont idle, new plugs, air / fuel filter, looking for ebs delete as in another post,

It will rev out up over 2/3 g's and sounds sublime, not sure if it needs a run to let the ecu calibrate when its on the road and hurling along at a pace,

We have no snow and places to go, I do feel ashamed you poor buggers have only so many days to ride,

I look out the window on a 26/32 c day and say nah, beers to good, see ya later,

:)
 

·
Registered
Joined
·
1,767 Posts
I feel your pain. What starts out as a minor quickly morphs into a major dismantle.

Walk away, think and consider the options, then go back when you are fresh.
The Touchup Guys might be worth a call, they do airbrush work, which will get you by until you do something permanent.
 

·
Registered
Joined
·
14,741 Posts
You have a 1.6M ECU it doesn't 'learn 'anything
Pay attention
 
  • Like
Reactions: flossy

·
Vendor
Joined
·
5,571 Posts
Won't idle,check vacuum hoses.
Changing tyres.I take my wheels to the bike shop.If they damage the rims it is their problem to replace the rims and believe me when you tell them the wheels are off a MV they take the utmost care.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #5
From another post, story so far

Thanks esky, re ebs

So I found it does affect the idle when I unplugged it, ran pretty rough,

A big thanks to an old poster about using a wet rag to see which pipe was not getting hot,

No 1 cylinder not firing like the rest, took out the new injector I had in it with another, swapped plug leads and an old plug to eliminate, with the suspect one and all pipes were running hot,

A short ride later it was better but still missing smooth operation around 3/4 thou revs, above that it was okay to a point,

I will check the eprom chip connection next and go from there,

I tested with and without the air box on to see if any change, nothing came of it, same symptons with or without, :unsure:

About doing my own wheels, I found it easier not to use the tyre machine but lay it on a blanket and go to town,

Changing the fork bushes and seals was another story, wrong size bigger bushes sent, aound 2/3rds of the height of the ones in it so reused them,

Tried to release the top nut while using the 19mm open ender slid under the spring, easy you say, I had the big socket winding away on outer top nut not the inner smaller one,

While the preload was doing up and spanner nearly slipping off the 19mm nut,

Walked away then tried it with the 14mm? smaller preload nut on top and bingo, I made up a whole list of new swearwords never before heard, my dogs reackon I was crazy,

Threw in a set of tmken front wheel bearings, the outer race is a lot smaller than what was in it, hub bearings looked okay as did the steering ones, greased them up, torqued the hub to

42 meganutans cause I don't want it to slip, :giggle: now the wheel wont spin, :p that way I can save on brake pads,

Slowly does it, part 3 coming soon, thanks amigos for your advices, :geek:
 

·
Registered
Joined
·
103 Posts
Discussion Starter #6
double imposterer
 

·
Registered
Joined
·
103 Posts
Discussion Starter #7
You have a 1.6M ECU it doesn't 'learn 'anything
Pay attention
So when I travel to the higher grounds at 2/3000 feet above sea level if its not the ecu that compensates for the colder thinner air to lean out the fuel/air ratio to keep it from bogging down,
Then what sensors pick up those changes and adjust the motor to run to suit the changing conditions, just curious,
 

·
Registered
Joined
·
103 Posts
Discussion Starter #8
front brakes are useless, cleaned discs, brake cleaned everything, looks like time to deglaze pads, [still plenty of meat on them] did i mention the turning circle requires a footy field to do a ui, :giggle:
 

·
Wing Nut
Joined
·
21,314 Posts
So when I travel to the higher grounds at 2/3000 feet above sea level if its not the ecu that compensates for the colder thinner air to lean out the fuel/air ratio to keep it from bogging down,
Then what sensors pick up those changes and adjust the motor to run to suit the changing conditions, just curious,
The Air Pressure and Temperature sensor, located in the left air tube, sends signals to the ECU for compensation.
The chip in the ECU has the tables for the map to make fueling changes as needed.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #10 (Edited)
Part 2

I thought I had it nailed except for the rough running, added a couple of new outside injectors 1/4 with broken tabs, trying to dial in the throttle sensor and air screws, hence the starting on off chewing up the new battery, pulled the headlight fuse to help some while playing about, bought the bike with a running issue thinking I'll sort this baby out in no time, new fuel / air filter, oil, coolant, plugs,etc, was not to bad till I took her for a couple runs, still a bit off thinking okay time for a new ebs, chip or flash in order,
I have one on order from the grand merc7, in the meantime she was still turning over like a donkey on hot sand, then slowly nothing at even wanting to fire, threw down the throat some contact cleaner while kicking over, it tried to fire, then some brake cleaner made it better, so I thought it was a fuel problem, so about to throw in another new filter and injectors when I decided to rip out the plugs, gave my new iridiums a good old wire brush to their tips with plenty of petrol in between and voila, she fired again, [I know they say don't wire brush them but I will be putting in another set when the chip arrives,
As for the ecu learning they obliviously need to correct fueling with altitude and air filter flow when they are not as clean from new,
I rest my case for now, cheers amigos, :giggle:
 

·
Registered
Joined
·
103 Posts
Discussion Starter #11 (Edited)
Part 3,

Along with the front pads not biting enough the rear static sag is okay but the rider sag is only at around 25 mill, I backed of the preload, compression, and rebound to zero, undid all the rear engine mounts, swing-arm and height adjusters and still stiff as a board, maybe time for a rear softer spring and service, normally they don't get harder only softer but its still pretty stiff at the rear, :)

New shoes with by best mate, Buddy,
Can't wait to rip the nipples of these set of hooters, :p
 

Attachments

1 - 11 of 11 Posts
Top