MV Agusta Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
397 Posts
Discussion Starter #1
Hi

Does anyone here know of a source of aftermarket O2 sensors to fit the tester socket in the standard (F4) link pipe? The thread appears to be 10mm.

Thanks.
 

·
Registered
Joined
·
14,676 Posts
wrong one Carl, he's talking about the sniffer ports M10 x 1.0

02 sensors are M18 x 1.5

the BMW (bike) oil pan drain pan plugs work as a block off.....use Never Seize on them EVERYTIME
 

·
Registered
Joined
·
1,233 Posts
Hi

Does anyone here know of a source of aftermarket O2 sensors to fit the tester socket in the standard (F4) link pipe? The thread appears to be 10mm.

Thanks.
Guess you have 3 choices:

1- Make an adapter to fit a standard sensor
2- Cut off the 10mm one, drill and weld in a proper o2 bung
3- Drill header pipe 1 or 1&2 and weld in proper o2 bungs

Cheers
Adam
 

·
Administrator
Joined
·
20,754 Posts
I tried to make a probe to screw into the tester holes for my gas analyzer...the 10 mm plugs I used didn't seem to want to screw in all the way.
I took the plug removed from the pipe and used my thread gage to discover the dang thing was BSP pipe thread!...I had the right die, so used that to rethread my home made plug....voila, screws in fully now.

Who would have thought.....but to answer the question, no O2 sensor in that size available.
 

·
Registered
Joined
·
14,676 Posts
thanks Ed, I stand corrected, looked like the 10mm ones on the Aprilia RSVR

what is the official thread?
 

·
Administrator
Joined
·
20,754 Posts
1/8 BSP worked for me.
 

·
Registered
Joined
·
14,676 Posts
Your getting forgetful in your old age Noel....
Here's one I made earlier with the measurement you gave me !

http://www.mvagusta.net/forum/showpost.php?p=439319&postcount=22
Adam;
I lost 4,000 bookmarks to a fucked up Opera browser up date......the size was in my technical stuff.....

in theory, they are somewhere on my Imac.....but the 2 shitheads on My Opera with 100,000 posts between them, won't give me the file name or path

Adam, I don't use sniffers, but digital Lambda meters and see it in real time......where the MV ports are, reversion will drive you nuts....especially with the pipes paired 1&2, 3&4 the firing order is screwed up, it should be 1&4, 2&3......

Rant on the UK Forum changed the pipes and reported a big improvement in smoothness
 

·
Registered
Joined
·
1,233 Posts
Adam;
I lost 4,000 bookmarks to a fucked up Opera browser up date
They were all from the 70's anyhow ! - sorry, couldn't resist lol

I know what you mean though, I lost a hard drive and a backup drive when the controller on my mobo died. Luckily it must have been the main drive that caused it all as with a new sata controlleer, the backup drive was ok :)

As for the sniffer, that was just to use on a bike that had no sensor bung but it connected to a digital lambda gauge.

My set up is headers 1 and 2 drilled and o2 bungs welded in...

Cheers Adam
 
1 - 10 of 10 Posts
Top