MV Agusta Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi All, whilst awaiting some parts to arrive I have given my bike a strip down and very careful jet wash and clean, anyway the sump was leaking cause loose bolts and 1 missing this has been rectified and left bike semi stripped turned the key and heard fuel pump go but no other electrics, found to be blowing fuse number 1, after stripping trunking back and checking previous repair to no avail then started unplugging things to eliminate cause, It was the 2 plugs by the side stand where I repaired sump I unplugged these and all was fine plugged back in wrong way around which caused no electrics as blowing fuse straight away swapped both plugs around and all is good, lesson learnt pay attention when unplugging things a lot of time and frustration blaming dodgy Italian electrics, simple mistake to make has anyone else done this (probably not lol) if you have taken things apart and have this issue this is the problem, Also put on different exhausts with no baffles how sweet it sounds this coming week bike will be insured and taken out for first good ride,
 

·
Super Moderator
Joined
·
22,450 Posts
Yes, this has been done before. It is hard to come up with an original sin.
 
  • Like
Reactions: MVBERT

·
Registered
Joined
·
6 Posts
Discussion Starter #3
That's reassuring im not the only fool, gave me a good chance to get to know the bike though DOH!!😂🤣🤣
 

·
Registered
Joined
·
2,818 Posts
I got tired of my simpleton errors and now take photos of certain things before disassembling.

It's easy for us to say: 'That'll be a breeze to remember', but how often do we forget that breeze?:rolleyes:
 

·
Registered
Joined
·
1,097 Posts
This would so help prevent those Battery reverse polarity threads.

And thanks for the chuckle chuck "It is hard to come up with an original sin." I like your dry humour, always therapeutic after a day at work!
 

·
Registered
Joined
·
14,532 Posts
PJ312R;
I did a sticky with this problem in it....
Now take 2 zip ties and tie them to both sides of 1 connection
 
1 - 7 of 7 Posts
Top