MV Agusta Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
306 Posts
Discussion Starter #1 (Edited)
No 4-Way Flashers with Integrated Tail Light with Veloce L Rizoma LED mirrors

I just noticed that my 4-way flashers don't work now that I have installed the integrated tail light I got from GPracing.

I also have the Rizoma Veloce L naked mirrors with LED lights to replace the OEM mirror/lights.

Functionality dies for turn signals until I turn off the 4-way switch AND cycle power on the bike. Must be a load issue on something. Not sure I will bother digging into it, I rarely use my 4-way flasher.

Anyone else notice this or similar issue with 4-ways with different turn signals?
 

·
Registered
Joined
·
175 Posts
:toothlessI don't even know where my 4 way flash toggle is


I have Rizoma Veloce L and a integrated turn signal rear. Will test out when I can.
 
  • Like
Reactions: falcn

·
Registered
Joined
·
495 Posts
Mehr Licht

Rumors say that somebody saw it below high beam switch, but that is just rumors.... :grin2::grin2:
Rumor has it that somebody sees things and also hears voices.
Mebbe changing OEM Turislow fairing screen for an aftermarket bifocal screen could help.
...I rarely use my 4-way flasher...
Only when changing engine map on the fly.
Bigus thumbus ...
 

Attachments

·
Registered
Joined
·
306 Posts
Discussion Starter #5
Rumor has it that somebody sees things and also hears voices.
Mebbe changing OEM Turislow fairing screen for an aftermarket bifocal screen could help.

Only when changing engine map on the fly.
Bigus thumbus ...
2010 B4 the switch is tucked up under the dash and you have to jam your finger in between the dash and the bar clamp to activate it. Not very convenient.
 

·
Super Moderator
Joined
·
22,851 Posts
Most bikes don’t even have this feature.
 
  • Like
Reactions: falcn

·
Registered
Joined
·
363 Posts
More new-fangled technology for the kid bikes :king:
 

·
Registered
Joined
·
306 Posts
Discussion Starter #10
Looks like I am the only one with the issue...
 

·
Registered
Joined
·
564 Posts
Wonder if this would fix it? https://evolutionbike.it/mvagustastore/8000b3217.html

Not really bothered by it, as I said. I don't use my hazards (or hadn't much) since the button is very hard to activate.
I dont think you need a new relay, I think you just need to fit the resistors . Did your mirrors come with extra resisitor kit ? my Rizoma mirrors did, but I didnt fit them...I have the same issue with the hazard flasher not working. Might give the resistors a try when I find time.
 

·
Registered
Joined
·
608 Posts
What year is your bike? Does ist have 3,2 Volt or 12 Volt indicators?
 

·
Registered
Joined
·
306 Posts
Discussion Starter #15 (Edited)
What year is your bike? Does ist have 3,2 Volt or 12 Volt indicators?
As it says in my Sig - 2010 Brutale 990R

I've never measured the power going to the signals, didn't know some were 3.2V. Everything works properly with the flashers. The blink speed is correct, except no 4-way.
 

·
Registered
Joined
·
306 Posts
Discussion Starter #16
I dont think you need a new relay, I think you just need to fit the resistors . Did your mirrors come with extra resisitor kit ? my Rizoma mirrors did, but I didnt fit them...I have the same issue with the hazard flasher not working. Might give the resistors a try when I find time.
I'd much rather fit an electronic relay that can handle reduced draw from LED signals than install resistors. I personally hate installing resistors on LED turns, and always swap to LED blinker relays. Of course the MV one is ridiculously expensive for what it is.
 
1 - 16 of 16 Posts
Top