MV Agusta Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
317 Posts
Discussion Starter #1
Hi!

Just got my Dragster RR back from 12000km service today, and it feels like the quickshift time up is longer than before.... Anyone else got that feeling? Wonder if its a new software or something.
Its no problem, but i think its more brutal and jerky when up shifting now :D
 

·
Registered
Joined
·
11 Posts
Done mine last month, however it's only the first 1000 km service and the bike is 2 months old.The dealer didn't do any software upgrade, best is to ask your dealer I suppose.
 

·
Registered
Joined
·
5,590 Posts
Mine was done last saturday and there were no software updates.
 

·
Registered
Joined
·
317 Posts
Discussion Starter #4
Ok :)
Then its probably just me :D
Thanks :)
 

·
Registered
Joined
·
97 Posts
Holy shit just realised you have 2 Lancia's. You lucky lucky man the EVOII has been my dream car since i was a teenager. Well done and enjoy. hopefully one day i can own one as they have always fascinated me :)
 

·
Registered
Joined
·
317 Posts
Discussion Starter #6
Holy shit just realised you have 2 Lancia's. You lucky lucky man the EVOII has been my dream car since i was a teenager. Well done and enjoy. hopefully one day i can own one as they have always fascinated me :)
Ha ha :D Thanks :)
The Bianco Perlato was imported from the UK in 2010, was bought on impulse :D The Price was good, but i can see why ..... spent about £10000 on welding and paint, but now it look like it should do :)
Coming up for sale ;)
The black EVO1 is a 8v, and bought that in 2000 :) Never going to sell that one :D
 
1 - 6 of 6 Posts
Top