MV Agusta Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone. I'm new to the group, so, thanks for accepting me. My oil light went on today after a 45 minutes ride. Ate there any known oil consumption problems? What else can it be?
Thanks in advance for your help.

Hugo
 

·
Registered
Joined
·
111 Posts
Oil light..check oil level. If it's ok, could it be the pressure sensor failing. If You have a gauge, check pressure.
 

·
Registered
Joined
·
14,621 Posts
Try using "Search"
The part number for the sending unit is in my big sticky
 

·
Administrator
Joined
·
20,534 Posts
Welcome to the family @Hugo F4 750 !!

The oil light is a low oil pressure signal. If your engine continued to run and did not start making horrid knocking sounds then it is likely just the sensor is failing or the wiring connections are bad.
Just like in your car, if you ride with the oil warning light on you could end up with a blown up motor.
There are prior posts as the Knurl indicated...do a search.
 
  • Like
Reactions: 312R Dan

·
Super Moderator
Joined
·
22,708 Posts
There is also the possibility of an oil viscosity issue. Make sure you are using a quality 10W60
 

·
Registered
Joined
·
111 Posts
There is also the possibility of an oil viscosity issue. Make sure you are using a quality 10W60
Pressure sensor it's rated around 9 psi. Its There any probability, any oil cause that pressure? I would look any sensor leak. It failed in mine a few tiene ago.
 
1 - 7 of 7 Posts
Top