MV Agusta Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi everyone,
i am a new owner for a 2014 (second hand) brutale 675 with 4000KM on ODO.

===========================================
1) the first thing i noticed on cold start is that it doesn't turn on as when it is warm. after searching the forum, i read lots on SPRAG CLUTCH change.

i asked the dealer and he said that for 675, there is no sprag clutch issue, this was only for 800s.
i was asked to try and turn it off then on and retry starting the bike in case it doesn't kick in the first time.

so wanted to check if this is an issue only for 800s or is the same sprag clutch set on all BRUTALE series?

===========================================

2) also, just wanted to know what is the date of the latest map updates released by MV. Also, my dealer said no updates for 675 :wtf:

can anyone just help me to have the correct facts so i can face my dealer with the answers above?

the bike had only 1 service till now, changed oil on 1000 KM.. and now its due for its second service.

thank you in advance for your help guys!:)
 

·
Administrator
Joined
·
20,360 Posts
Welcome to the family!!

Pretty sure there were LOTS of map updates for the early 675s. What year is your? New ones are probably up to date.
Can't speak for the sprag.
 

·
Registered
Joined
·
1,511 Posts
I suspect your dealer is clueless, is there another MV dealer within easy reach?

Early bikes had lots of map updates as Ed said, 675's have had a few sprag clutches but I would get the map updated and ride and see if that helps first.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Thanks for the update guys...
the thing is that we have only 1 MV Dealer...
just wanted to check where i can see the last released Map updates per model so that i can have an idea...

any ideas about the Sprag Clutch if 675s are affected?

mine is MY 2014
 

·
Registered
Joined
·
1,550 Posts
Hi everyone,
i am a new owner for a 2014 (second hand) brutale 675 with 4000KM on ODO.

===========================================
1) the first thing i noticed on cold start is that it doesn't turn on as when it is warm. after searching the forum, i read lots on SPRAG CLUTCH change.

i asked the dealer and he said that for 675, there is no sprag clutch issue, this was only for 800s.
i was asked to try and turn it off then on and retry starting the bike in case it doesn't kick in the first time.

so wanted to check if this is an issue only for 800s or is the same sprag clutch set on all BRUTALE series?

===========================================

2) also, just wanted to know what is the date of the latest map updates released by MV. Also, my dealer said no updates for 675 :wtf:

can anyone just help me to have the correct facts so i can face my dealer with the answers above?

the bike had only 1 service till now, changed oil on 1000 KM.. and now its due for its second service.

thank you in advance for your help guys!:)
Welcome to the addiction. :)
Do a search on this forum and you’ll find your answers, LOTS of them.
I was told the same thing about the sprag and so nothing was done until my F3 675 started to make the most horrendous noise. :jsm:
Then it was; “Oh yeah, that’s the sprag all right. We’ll get one on order for you.” :loser:
The B3 updates are different to the F3 so I can’t help there. MV used to post the latest map release dates on their website but they stopped doing that. (Gee I wonder why??)
Best thing is ride your bike. If you like it, leave it alone. If you find it’s giving you problems then be very specific as to what its doing that you think is wrong and this community will do its best to point you in the right direction. Do not fall into the trap of believing that everything can be fixed with a new map. :ahhh:
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Welcome to the addiction. :)
Do a search on this forum and you’ll find your answers, LOTS of them.
I was told the same thing about the sprag and so nothing was done until my F3 675 started to make the most horrendous noise. :jsm:
Then it was; “Oh yeah, that’s the sprag all right. We’ll get one on order for you.” :loser:
The B3 updates are different to the F3 so I can’t help there. MV used to post the latest map release dates on their website but they stopped doing that. (Gee I wonder why??)
Best thing is ride your bike. If you like it, leave it alone. If you find it’s giving you problems then be very specific as to what its doing that you think is wrong and this community will do its best to point you in the right direction. Do not fall into the trap of believing that everything can be fixed with a new map. :ahhh:
THanks Stephen..
i love the bike.. but asking about the map is related to the following behavior:

The throttle response is quirky on low RPM between 1500 & 2000. it doesn't feel like it's steady. is this something you find on the F3?

i`ll keep a search on related topics in the forum.
Thanks for the update :)
 

·
Registered
Joined
·
1,188 Posts
Lots of people have the same issue and I suspect that 800 and 675 will be the same.
In my experience (800) a new battery made a big difference, a map update made no difference, a new throttle made a big difference, a new exhaust manifold gasket made a difference, synchronising the throttles made a huge difference. The sprag noise has almost disappeared since the new battery so I guess I got it in time. Its a high compression motor. If the battery doesn't have the juice to spin it over the sprag slips. If the sprag slips it wears. If it wears it slips. Classic downward spiral.

Get a decent battery first.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Lots of people have the same issue and I suspect that 800 and 675 will be the same.
In my experience (800) a new battery made a big difference, a map update made no difference, a new throttle made a big difference, a new exhaust manifold gasket made a difference, synchronising the throttles made a huge difference. The sprag noise has almost disappeared since the new battery so I guess I got it in time. Its a high compression motor. If the battery doesn't have the juice to spin it over the sprag slips. If the sprag slips it wears. If it wears it slips. Classic downward spiral.

Get a decent battery first.
Thanks Jono...
well i guess its obvious that i just cant go to the dealer asking for a new battery without having the current one doing different issues. i`ll check this week to see what happens (if it runs or not) and for that i will try and tell the dealer the issue. It's time for it to go to the dealer. so i`ll see what to do.
 

·
Registered
Joined
·
895 Posts
I don't think Jono is talking about a warranty on the battery. The standard battery in these bikes are in general very poor quality. You will be better off paying for a good quality battery yourself. As to throttle response from 1500-2000rpm I would suggest using a lower gear and not trying to cruise at anything below 4000rpm, you and your engine will be much happier.:)
 

·
Registered
Joined
·
58 Posts
I have a 675 B3, and the quirkyness you talk about its always there at low revs. On mine it was worst on the first 1000km, and after the first service they updated the map and the throttle i guess, because it became much smoother, but not perfect. Still today its not smooth.

On other bikes i used to cruise at low revs a lot, but on this bike i cant. Just need to get used to cruising at 4k rpm or higher ahah
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
I don't think Jono is talking about a warranty on the battery. The standard battery in these bikes are in general very poor quality. You will be better off paying for a good quality battery yourself. As to throttle response from 1500-2000rpm I would suggest using a lower gear and not trying to cruise at anything below 4000rpm, you and your engine will be much happier.:)
if not mistaken the battery is covered under warranty, yet i need the dealer to acknowlege it needs replacement. as for the throttle response i am using 1st gear to drive out of a parking lot where i park my bike. i used to own a CBR 600RR and a steady throttle all the way up from underground, this is not possible to say the least with the brutale.

I have a 675 B3, and the quirkyness you talk about its always there at low revs. On mine it was worst on the first 1000km, and after the first service they updated the map and the throttle i guess, because it became much smoother, but not perfect. Still today its not smooth.

On other bikes i used to cruise at low revs a lot, but on this bike i cant. Just need to get used to cruising at 4k rpm or higher ahah
its not about cruising, ye its very bad when you want to take the bike in a O shape parking lot underground going up from -3 ... its scary that it might get crazy on that low level RPM.. so either use friction zone all the time or keep padding the rear break until i reach level 0 and i`m in the clear!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
i`m going to try the CUSTOM MAP this weekend to check on it.
made some research on this forum and seems many are stating to try and decrease the Gas Sensitivity to Normal .. will check on that and let u guys know what would happen..

thanks again for all your inputs! :)
 

·
Registered
Joined
·
895 Posts
If your dealer does agree to replace the el cheapo standard battery under warranty, he will replace it with yet another el cheapo battery. Do yourself a favour and buy a QUALITY battery. I would also recommend leaving the carpark on the back wheel.:f4:
 

·
Registered
Joined
·
13 Posts
Discussion Starter #14
If your dealer does agree to replace the el cheapo standard battery under warranty, he will replace it with yet another el cheapo battery. Do yourself a favour and buy a QUALITY battery. I would also recommend leaving the carpark on the back wheel.:f4:
will check on the battery once i see it needs change. i guess already he is getting another brand now not the cheapo one anymore.

as for the back wheel , i agree, the friction zone is very close and it might make the brutale hop forwards! so :f4:
 

·
Registered
Joined
·
58 Posts
Yes, i usually use the Custom Map.
With the throttle on Rain sensitivity it does help a bit.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #17
After it was for service, the bike wouldn't start easy at the dealer.. so eventually got a change for the starting kit covered by the warranty. at least that's out of the way...

seems the battery is in good shape. nothing to fix on that end.
 
1 - 17 of 17 Posts
Top