MV Agusta Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1 (Edited)
Hi - have had my 990r for a couple of weeks now and must say that it is a brilliant road bike after 400 miles or so ... coming from a ZX-10R the ability to really hustle the Brute is giving me lots of satisfaction! I do have a couple if questions/comments though ...

The swing arm has patchy reddish/black colour with what looks like oil residue on it and so does both bits that are on the side of the bike that look like the same material as the swingarm (will be replaced at first service so no big deal IF it gets sorted).

I have decided that I do not like the mirrors so will fit bar end mirrors soon ....

For extended trips I want to put a small touring screen on it - something easy to fit & remove as and when necessary. Luggage will be a tank bag plus bungied rucksack !!

Town riding is a pain as the throttle is very snatchy low down and it seems to 'phut' out of the airbox a lot when on transferring to small part throttle with the transmisison unoading/loading with the associated clunk (like it cuts out momentarily)!!

The engine has cut out on me twice under heavy braking into a corner to leave no throttle just when you need it to pick the bike up again!!

I have taken it to 10k rpm or so on a couple of occasions and in 1st gear the fuelling seems really crap above 8k where the power is noticibly backed off and it sounds a bit like a misfire, however 2nd and 3rd are better though.

Dealer says the cut outs/'phatting':)))/snatchiness is just the new engine running in MV style and I say I have never had this before and I have run in 4 new bikes before (one of them a 996) - what do you guys think?

Apart from that - when I am on it and keep the throttle nailed (as much as I can at this stage!!) it all works lovely :) In fact, I think that it is near on a perfectly balanced bike for real world stuff ... will track it next year and hopefully challenge a few sportsbikes !!




 

·
Registered
Joined
·
1,499 Posts
Welcome, and those wheels are great
 

·
Premium Member
Joined
·
2,563 Posts
Welcome to the family Ninja and congratulations.

I think a couple of the 990r and 1090r owners on here may be in a better position to advise - (how many Km's do you have on the bike....ie. did you purchase brand new ? this might help some of the fuelling / tuning demi-gods who reside within ;-)

Cheers
 

·
Registered
Joined
·
25 Posts
I have a 1090 with about 400miles on it so far. Its cut out on me twice. First time was on 100+ deg F day just closed the throttle prior to entering round-about and it shut down. Fired right back up and ran shitty for a couple minutes then it was fine. Second was a 70 deg F day. Just shut down on decel. Again ran shitty for a couple minutes and then it was fine. Also noticed the other day that it seems to get stuck at a high idle when in sport mode. Just figure I'll remove some of the emissions stuff this winter, maybe different exhaust and see if it makes a difference.
 

·
Registered
Joined
·
178 Posts
My 1090 used to cut out when new under hard breaking. Went away once it was broken in. It will still stall occaisionally when not warmed up under decel. No big deal.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #6
Have done 400 miles from new :) It cut out on me yesterday again under hard decel - but the fuel light was on so probably a low fuel thing. That'll be a pain on track!

Sounds like the other engine effects I am noticing are probably due to a tight engine as it is new bike that I am running in and will aleviate in due course. Just seeking a second opinion really ...
 

·
Registered
Joined
·
365 Posts
Congrats on the purchase BlackNinja, I am sure you will love the bike even more as time passes by. I had a similar problem of the bike cutting off during deceleration and braking but it was because the bike was not tuned properly (the rpm was set below normal idle), once that was taken care off not a problem at all. These bikes are very sensitive to tuning and set-up. Enjoy the rides.
 

·
Registered
Joined
·
1,175 Posts
As said by the other guys, get it tuned and that should fix all the issues. Why it doesn't work well from the factory i have no idea, Ducati do the same.

BTW how many Fkn Ninja's do we have on here? Seriously. Every thread i read there is a Ninja of some description. Are you guys Mexican or something?
 

·
Registered
Joined
·
69 Posts
Discussion Starter #9
As said by the other guys, get it tuned and that should fix all the issues. Why it doesn't work well from the factory i have no idea, Ducati do the same.
Looks like a PC and dyno run is in order then methinks ... :brutale:

BTW how many Fkn Ninja's do we have on here? Seriously. Every thread i read there is a Ninja of some description. Are you guys Mexican or something?
:yo:I've had that nick for a long long time :) Then I owned one for 6 years !!
 
1 - 10 of 10 Posts
Top