MV Agusta Forum banner

21 - 31 of 31 Posts

·
Registered
Joined
·
1,628 Posts
They are great bikes for sure, glad to see that you're enjoying it.

The noise on start-up after a period of inactivity is likely to be excessive cam chain slack. The tensioner is oil pressure actuated and if all the oil has drained to the sump it doesn't allow the tensioner to engage properly. Just stop and re-start and all will be well. The clutch is noisy too but that's normal, if it goes away when you pull in the lever then there's no issue. There was a service bulletin on earlier pre 2017 models that entailed fitting some new clutch parts that were meant to help but frankly I didn't notice any difference with mine, might also be a durability thing so worth checking the record on the bike to ensure that this work has been done.
 

·
Registered
Joined
·
218 Posts
Discussion Starter #22
Good news today, MV are supplying new sprag at no cost just have to pay for 2 hours labour. Taking her in next week.
 

·
Registered
Joined
·
371 Posts
Hope it not like my service experience. My sprag visit with Hourglass Motorcycles in Cummings, Ga., took three months in the spring! My valve service took one month at another MV certified shop.

2nd bike? I finally got one, but hope not to visit MV service centers any time soon.
 

·
Registered
Joined
·
218 Posts
Discussion Starter #24 (Edited)

·
Registered
Joined
·
218 Posts
Discussion Starter #26
So, got the sprag changed today, lots of chatter marks on the face so all good but being a new MV dealer they are still waiting on the diagnostic machine to arrive so couldn't upgrade the ecu. Another 500km/ 5 hour trip, 😞
 

·
Registered
Joined
·
158 Posts
still waiting on the diagnostic machine to arrive so couldn't upgrade the ecu. Another 500km/ 5 hour trip,
What happened that you are needing a new ECU? Or are you going to a tunable ECU?

I took mine in for the rear preload bracket recall and was having some starting issues and I was praying it wasn't the sprag. Turns out it was the battery! That's easy enough.

Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
218 Posts
Discussion Starter #28
What happened that you are needing a new ECU? Or are you going to a tunable ECU?

I took mine in for the rear preload bracket recall and was having some starting issues and I was praying it wasn't the sprag. Turns out it was the battery! That's easy enough.

Sent from my SM-G930V using Tapatalk
No just an ugrade to the software that is part of the sprag starting problem, you need to get both done.
 

·
Registered
Joined
·
218 Posts
Discussion Starter #29 (Edited)
Changed the oil today as it hit 10k, what i thought was going to be a half hour job turned into 3 hours!!!
Don't think the oil had been changed before as the three allen head screws holding the filter in we're seized solid, ended up having to drill them out and use an easy out tool to remove them, (scews heads just rounded off made from crap metal )ffs....Replaced with good torx screws.
Anyway all good now, seems to be a bit smoother on take off ��
 

·
Registered
Joined
·
158 Posts
Wow sorry to hear that. You never know what the "other guy"did until you get in there. Congrats on joining the 10k + club!

Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
26 Posts
21 - 31 of 31 Posts
Top