MV Agusta Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1,087 Posts
Discussion Starter #1
So drop the girl at dealer last week before I went away to have new tank installed and TPS set and tuned to get rid of hick up and low RPM stall. Didn't talk the service manager until last Sat when I got home so here is what is going down.
Tank is on and good! HURRAY!! The stalling not done?? :eek: Why I ask?, The shop called Cagiva US and sked them WTF is going on with the stalling issue?? They said order a new computer and that will fix it, so they did. 2 hours after ordering the computer Mr. Ferracci calls to speak with service manager and asked him why they needed a computer?? So he explained and told him what Cagiva said. NO MR.F says you need a new CDI that is what is F'ng the bikes up !
So I have a new CDI on order which is back ordered. Some will say "figures they never have parts in stock" But the bottom line in they have a new supper seaded part number for it which usually means it is a new or redesigned part so they will change the part number. The shop is confident that if Mr.F says that's the problem then that is problem? They were also given a check list to go through after they install new CDI so I will cross my fingers!
For the record I do have confidants in the shop and they were schooled at Mr.Ferracci's facility so in my opinion schooled by the BEST! I will follow up on work and tell all of my findings. Let me go so I can pick the bike up and ride her for mean time. L8r :moped:
 

·
Registered
Joined
·
243 Posts
Wow! And I thought that I was the only one with Brute problems.

What happens if Mr. F is wrong? :)

Seriously, good luck in getting the parts needed. Over two months waiting on a fender I can imagine how long it will take to get a new CDI.
 

·
Registered
Joined
·
1,087 Posts
Discussion Starter #3
As long as it's not hot out which for me it won't be so bike won't stall and winter is coming so I will be patient!
 

·
Registered
Joined
·
27 Posts
I just got my bike back from the shop after 6 weeks wait on the CDI.....Long wait but it was worth it my brut runs smooth and no stalling yet....Good luck with yours
 

·
Administrator
Joined
·
20,019 Posts
My '08 has never stalled??? Maybe I already have updated CDI. But surge at steady cruise 6~65K rpm is waiting on new ECU to fix. But I can live with that. It's not so bad and I can always speed up or slow down if it annoys me (which it hasn't yet).
Remonds me, I need to call dealer tomorrow for update on ECU.
 

·
Registered
Joined
·
571 Posts
Which new ECU do you speak of esq'z me?

I wonder if that ECU would be a better alternative for my Brutale S!
 

·
Registered
Joined
·
1,087 Posts
Discussion Starter #8
Surging I can deal with when I get it back. The stall issue is what I hope is cured if not then we start all over. Anyone like to educate me on the function of the CDI since I never asked the service manager that question??
 

·
Administrator
Joined
·
20,019 Posts
Vlad Drac said:
Which new ECU do you speak of esq'z me?

I wonder if that ECU would be a better alternative for my Brutale S!
When I took delivery there was an issue with severe surge at 5500 rpm steady cruise. The dealer "tuned" around it with fuel trim and careful adjustments, but it is still there (although at 6500 now and not near so bad). This is the new Euro 3 closed loop O2 sensor system. My '08 910R was the second one the shop had sold with this same concern. Cagiva had said they would have a new ECU to address this, and it was being sent out shortly (this was mid-August).

I'm still waiting. Forgot to call for an update today. I spent the morning taking a ride in a WWII B-17G bomber (quite an experience) and riding my bike up to Road Atlanta for the WERA Nationals. So I was distracted.

But never any stalling. And averaging 36 mpg over last 1000 miles!!!
 

·
Registered
Joined
·
8,920 Posts
CDH,

Is the CDI THE fix?!?!?!?!?

Please tell me yes, I'm hoping this will cure my life-threatening problem :banghead:
 

·
Administrator
Joined
·
20,019 Posts
CDH,

Is the CDI THE fix?!?!?!?!?

Please tell me yes, I'm hoping this will cure my life-threatening problem :banghead:
I am sorry, but I couldn't say if the ECU is the fix for your problem. Your tale of shutting down on the highway at speed is quite disconcerting. My '08 has never had a stalling problem.

Question?: prior to this last very scary series of stalls, did you have any work done, or other service? I wonder what could have prompted such a sudden worsening of symptoms? It really sounds like one of 2 things is happening to your bike:

A) the fuel system is losing ability to supply fuel pressure to the injectors (clogged filter, broken or loose line in the tank, blocked tank venting).

B) ignition spark is failing from a component that is breaking down with heat (bike starts after sitting for a bit).

I lean toward fuel supply issues from what I read you saying. Simple fuel trim problems would not manifest at speed like you have described. I wonder if you have a filter blocked up? Test fuel pump volume, not just pressure. You can have good pressure and yet the pump supply insufficient volume of fuel to keep the engine going. Happens all the time.
 

·
Registered
Joined
·
1,087 Posts
Discussion Starter #12
CDH,

Is the CDI THE fix?!?!?!?!?

Please tell me yes, I'm hoping this will cure my life-threatening problem :banghead:
I guess your asking me? My issue isn't like yours mine only happens at low RPM's never at speed. My bike got fixed and weather cooled down around me so bike was never put to high heat situations which was when it did it the most. I finally recieved my second new tank today :yo::) so I'm going to try and get the bike down to the shop in the next few weeks just as long we don't get anymore snow. When it goes in it will be getting everything done all over again, TPS,O'2's,muffler bearings, etc,etc. Be honest it has had a hick up or two but hadn't stalled, so not sure if she is 100%
 

·
Registered
Joined
·
1,087 Posts
Discussion Starter #14
Its a Coil Pack Ignition module it has to do with the ignition. Thats all I know!
 

·
Registered
Joined
·
8,920 Posts
I guess your asking me? My issue isn't like yours mine only happens at low RPM's never at speed. My bike got fixed and weather cooled down around me so bike was never put to high heat situations which was when it did it the most. I finally recieved my second new tank today :yo::) so I'm going to try and get the bike down to the shop in the next few weeks just as long we don't get anymore snow. When it goes in it will be getting everything done all over again, TPS,O'2's,muffler bearings, etc,etc. Be honest it has had a hick up or two but hadn't stalled, so not sure if she is 100%
Ha, thanks, I don't know where CDH came from...
 

·
Registered
Joined
·
8,920 Posts
HAHA LOL, I just realized it's an architecture firm I interned at several years ago in Georgia, whoa, that's weird.
 

·
Administrator
Joined
·
20,019 Posts
Actually...CDI would be acronym for Capacitor Discharge Ignition. A type of ignition used in motocross bikes and others and typically works without battery power, although there are some DC-CDI systems in use (ATV and Dual-Purpose bikes in general) which do utilize battery power instead of magneto coils.

Our bikes use a 12 volt electronically controlled ignition that is part of the Electronic Fuel Injection system (or EFI). The "black box" that controls all this, including the spark, is the Engine Control Unit (or ECU), also sometimes called the Engine Control Module (or ECM). Honda has their own name for it (don't recall exactly what...they always have to do it their own different way).

MV spec sheets call our ignition system "Induction Discharge Ignition". Still a 12 volt coil controlled by the engine management system.
:blah:
 
1 - 18 of 18 Posts
Top