MV Agusta Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
917 Posts
Discussion Starter #1
Hey y'all- I'm looking fo some help. I've got an '06 Brutale. The low beam stopped working. Thought it was the bulb. It's not the bulb. There is an adapter that allows the H7 bulb to fit into the wiring harness, which is sized to accept the prongs of an H4 bulb. This adapter somehow got heat damaged. I cannot seem to find a replacement.. It is marked "Stanley" with a part number, but the closest dealer to me (AZ) was of no help, I can't seem to find an H7 to H4 adapter online, and it seems a bit too much to try to replace the socket. An H4 bulb won't fit in the headlight housing, I tried.
This is the part that fried:
Any help?
Thanks,
Michael
 

Attachments

·
Registered
Joined
·
975 Posts
Have you tried Cag, I`d be surprised if he didn`t have one. I have one I think but will have to check for sure but since I`m in Australia it might take a little while to get to you. Will check and let you know.
 

·
Registered
Joined
·
917 Posts
Discussion Starter #5
Have you tried Cag, I`d be surprised if he didn`t have one. I have one I think but will have to check for sure but since I`m in Australia it might take a little while to get to you. Will check and let you know.
I did try CAG, of course. Unfortunately he couldn't help. If you had an extra that'd be awesome. Of course I'll cover expenses and postage. The other solution I can think of is to replace the stock H4 socket with an H7 one, but I'm pretty electrically dumb...
Feel free to PM or email me- thanks,
Michael
 

·
Registered
Joined
·
917 Posts
Discussion Starter #6
Hi Knurl- Thanks for that. I did see those, but they are simply the H7 socket which I would have to wire into the harness, removing the stock H4 one. A little confusing for me as that part is a two wire job, but the stock one has three wires to allow for the fact that the high and low beams are in series. I may have to go that route though...
 

·
Registered
Joined
·
917 Posts
Discussion Starter #7
Off topic, how are fires out there?

Hope you're safely away.
Mostly just smokey here in Santa Fe, depending on the wind. No real property damage, knock wood. Both are still burning pretty well, but nothing compared to last year's record setter. Hard to believe there is still more left to burn. And it's only the begining of June:wtf: We need some rain badly! Thanks for checking in though.
 

·
Registered
Joined
·
975 Posts
I did try CAG, of course. Unfortunately he couldn't help. If you had an extra that'd be awesome. Of course I'll cover expenses and postage. The other solution I can think of is to replace the stock H4 socket with an H7 one, but I'm pretty electrically dumb...
Feel free to PM or email me- thanks,
Michael

I`ve got one from my spare headlight shell, let me know where to send it ,. it`s a public holiday here tomorrow so it will be a couple of days till I can mail it. Mail usually takes about two weeks to the U.S. maybe a bit less.
 

·
Registered
Joined
·
917 Posts
Discussion Starter #9
I`ve got one from my spare headlight shell, let me know where to send it ,. it`s a public holiday here tomorrow so it will be a couple of days till I can mail it. Mail usually takes about two weeks to the U.S. maybe a bit less.
Sent you an email (used the address from your profile page) Thanks!!
Michael
 
1 - 9 of 9 Posts
Top