MV Agusta Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
758 Posts
Discussion Starter #1
Anybody else that has had a leaky radiator on their B3? Mine has sprung a leak where the clutch cable is routed on the radiator. On the right hand side of the bike runs a bolt straight through the radiator. On the other side is a routing clip.

http://shop.startwintrading.com/en/products/b3/new-folder-3/cooling-system-174
See part #19

Should not happen after 13k km. First major issue with the bike. :) Too bad 3 months out of warranty but i trust it will be sorted by MV. :yo:
 

·
Registered
Joined
·
181 Posts
Yep, mine developed a leak in on the right side near one of the brackets. Happened after about 4000 miles under warranty. That's just one of many, many issues I've had with the bike. It's a pricey fix, good luck.
 

·
Registered
Joined
·
758 Posts
Discussion Starter #3
Good to know i'm not the only one, that makes a warranty claim a bit easier. :)
 

·
Registered
Joined
·
95 Posts
I've wondered what that bolt was doing there. Should have had a closer look. 10,000km here. No leak and now fingers crossed!
 

·
Registered
Joined
·
216 Posts
Mine happened around 3k miles and covered under warranty. Hope it helps you out!
 

·
Registered
Joined
·
5,590 Posts
It seems a bit funny place for a bolt...
 

·
Registered
Joined
·
5,590 Posts
I will maximize the use of the QS not stressing this area ;)
 

·
Registered
Joined
·
758 Posts
Discussion Starter #10
No news from MV in two months time. New part delivery time would be between 2 and 8 months. Can't wait that long so took it to a radiator revision guy. Surprised to see the leak is not near the clutch cable clip but the radiator bracket.
Still the clip took out a good mm of material so i'm not putting it back. Need to find a new way to route the clutch cable.

Anyhow, will be fixed within a day so i can ride it this season.
 

·
Registered
Joined
·
65 Posts
I had a split tube which caused the rad to leak in the same spot mentioned by everyone else.
Covered under warranty, took over 2 months to get replacement rad.
 
1 - 11 of 11 Posts
Top