MV Agusta Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
My F4 has been stood for some time and it has a bit of a coolant leak. I see from other posts that its a common problem but where will it be coming from and is it an easy home fix?

Cheers
 

·
Registered
Joined
·
13,695 Posts
Depends where it is leaking from. I assume it is not overflow from the expansion tank?

CAG
 

·
Registered
Joined
·
4 Posts
What year is your bike? If it is a 1000cc then your most likely cause is the
O-rings in the water pump. It's a common problem from the factory. Have the dealer change them out and it will resolve your problem. Been there done that.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #4
Bike is a 53 plate 750 ( Thats a late 2003)

Its only done 272 miles in all that time and i bought it in April and havent been able to use it till i have 2 years no claims bonus.

I will check the overflow first but its leaking when its stood and hasnt run. Not a lot but a small puddle.

May simply be lack of use? Ill be changing that aspect of its life as of next month!
 

·
Registered
Joined
·
418 Posts
If not using the bike, do you at least run the motor for a while in the garage to get the juices moving/keep parts lubed etc.? Probably wouldnt hurt.
 

·
Registered
Joined
·
8,920 Posts
The seals in the water-pump housing will dry and shrink when not used; That's actuall what often causes them to leak when the bike is 'new' but likely sitting for some time.
Mine leaked for the fisrt 300 miles or so, then stopped on its own.
 
1 - 6 of 6 Posts
Top