MV Agusta Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
383 Posts
Discussion Starter #1
I've been having a combination of battery and cutting out problems lately. I use a battery tender when not in use and just noticed today that my bike was struggling to start.

It usually fires up right away but this time it kind of struggled (kinda felt like when you have a dead battery and the bike is trying to start but the lights are dimming and all) and then finally fired up.

After about a 45 minute ride, I got back home, turned it off and tried starting it again, it struggled and then fired up.

I then proceeded to repeat the process, still struggled but with a twist of the throttle, it fired up.

I tried it one more time and I think I might have held the button too long...
so now it doesn't even turn over or anything.... :bawling: I'm not sure if I just drained the battery or if I did damage to the electrical system....

Help....! :cry:
 

·
Registered
Joined
·
3,255 Posts
sounds like a weak battery that wasn't taking a charge. i'd check the 2 fuses on the left side that handle the charging circuit.
 

·
Registered
Joined
·
383 Posts
Discussion Starter #3 (Edited)
Style: Checked those two fuses and all the others, they aren't blown out.

Yeah, I hope I didnt damage the starter motor...I hear clicking when I push the ignition button....gonna fully charge the battery first before assessing the situation further.

forgot to mention, Its a brand new battery too..12A :bash:
 

·
Registered
Joined
·
5,193 Posts
outtadaloop said:
Style: Checked those two fuses and all the others, they aren't blown out.

Yeah, I hope I didnt damage the starter motor...I hear clicking when I push the ignition button....gonna fully charge the battery first before assessing the situation further.

forgot to mention, Its a brand new battery too..12A :bash:
Theres a large fuse on the rear of one of the relays on the LH side of the bike, there's actually two there, one is a spare, I think from memory its the alternator fuse and about 30 amp rating, if its blown the battery won't charge from the bike
 

·
Registered
Joined
·
383 Posts
Discussion Starter #5 (Edited)
All my battery problems started after I installed the Clear Alternatives Tail light, maybe I wired something wrong or maybe I didnt tighten the battery cables after installing the new one, gotta check these things.

Update: Fully charged battery, but it wont start. I hear one click when I push the start button and thats it...gotta check the starter relay, hopefully its not the starter motor. :eek:
 
1 - 5 of 5 Posts
Top