MV Agusta Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hey all just recently aquired a 2007 910R here in the states. Tried a search but did not see anything specific.

Bike came to me with the cat-delete mid pipe and Corse exhaust installed, I also got the stock exhaust and cat plus the little box with an EPROM in it.

Bike was not running when I got it do to dead battery but I am slowly going through it, fresh fluids through out today and new chain, battery etc etc.

My question is previous owner said he put stock EPROM back in as it ran better, the one I have in the little black Corse box has a yellow paint dot on it...but no "corse" markings...pulled ECU tonight and took off rubber cover, did not pull EPROM but it doesnt look like anything special!

How do you tell which is which? Only got a short ride on it as it sits and once warm fueling seems ok...no stalling in my short ride and since the bike has 17K miles I assume it goes for the most part....but I want to try the race ECU since the exhaust is fitted and see how it runs!


Thanks for any tips...cool bike, going to look at the cam chain tensioner and rear hub next.... :blah:
 

·
Registered
Joined
·
14,532 Posts
chips anyone?

Glenns;
sounds like you need some one to 'read' the chip

try calling Doug Lofgren 612-718-7914 and see what he says
 

·
Super Moderator
Joined
·
22,072 Posts
Hey all just recently aquired a 2007 910R here in the states. Tried a search but did not see anything specific.

Bike came to me with the cat-delete mid pipe and Corse exhaust installed, I also got the stock exhaust and cat plus the little box with an EPROM in it.

Bike was not running when I got it do to dead battery but I am slowly going through it, fresh fluids through out today and new chain, battery etc etc.

My question is previous owner said he put stock EPROM back in as it ran better, the one I have in the little black Corse box has a yellow paint dot on it...but no "corse" markings...pulled ECU tonight and took off rubber cover, did not pull EPROM but it doesnt look like anything special!

How do you tell which is which? Only got a short ride on it as it sits and once warm fueling seems ok...no stalling in my short ride and since the bike has 17K miles I assume it goes for the most part....but I want to try the race ECU since the exhaust is fitted and see how it runs!


Thanks for any tips...cool bike, going to look at the cam chain tensioner and rear hub next.... :blah:
I know none of these are for the 910R, but you never know with all the chopping and changing going on - http://mvfaq.blogspot.com.au/2006/06/eprom-exhaust-chip-cross-reference-hit.html
The best is to swap the chips and test them yourself, are you near someone who can help you re-set the TPS ?
 

·
Registered
Joined
·
131 Posts
I had the same experience. The performance EPROM made my bike stall when pulling the clutch in. it was super annoying. The dealer put the regular chip back in & it stopped stalling.


I'd keep the stock chip in if i were you. As fast as the bike is, I doubt you will notice a difference.
 
1 - 4 of 4 Posts
Top