MV Agusta Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hello All,
I'm hoping someone can give me some advice. My 2001 F4750 just cuts out and won't start again until it has cooled down. It will run for maybe 20 minutes then just cut out. I get all working electrics (dash, lights, horn, etc) and it cranks over but won't fire. Leave it for maybe an hour and it starts straight away, but then cuts out again 15-20 mins later. I'm assuming a hot running issue (I live in Hong Kong and it's about 30 degrees at the moment), but have no idea what the problem is.

My mechanic just changed one of the main leads running from the battery as it was overheating and a fuse was blowing as a result, but this ongoing issue I have can't be a fuse as the bike starts again once it has sat for a while so nothing is actually physically broken.

Does anyone have any suggestions for where I can start looking for the cause as my mechanic and I are struggling?

Many thanks.
 

·
Registered
Joined
·
9,963 Posts
Im thinking good possibility of a fuel delivery issue...

check the fuel filter service status ie when was it last changed ? , lines (and airfilter while you are at it )
 

·
Registered
Joined
·
2 Posts
Well, actually engines are more or less simple - air and fuel means BOOM. So i can only agree with "gotojoe" - a fuel delivery or air delivery issue are possibilities - the other possibility is the spark plugs.

When you drive it for 15 to 20 minutes - does it feel "normal"?
 

·
Registered
Joined
·
1,558 Posts
Do the fans turn on before it stalls or does it stall before or as soon as the fans start up?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
Yes I was thinking maybe a fuel issue. The bike runs perfectly until it stops then it cuts out as if you've hit the kill switch - no gradual hiccup or problem, just a dead stop. After a while it starts again perfectly on the button. Odd.

The fans are always on when it stops as they are on most of the time since it is so hot here! I haven't noticed a link between the fans coming on and the bike stopping to be honest.

Thanks for the replies so far - any more would be hugely appreciated!
 
1 - 5 of 5 Posts
Top