MV Agusta Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
Brutale dragster 800 rr MY15.

So the dreaded gremlins have appeared again. Why are the electrics on MV's so crap?!

Went out this morning, and it started fine. travelled a few miles down the road and filled it up with petrol. Then no go. Had the batt volt msg come up on the dash.

Waited for recovery, who couldn't work out where to start from relay, so was going to lift tank to get to the battery, when he checked it started.

So I road it home to put it on charge and swap it out for my other bike.

abs light comes on, malfunction, no abs, then it completely died. fortunately, I was just turning into my road so I coasted to my garage.

I've put the thing on battery tender charge now, may swap out the regulator/rectifier.
Hoping it's not the alternator that was put in not too long ago.

Anyone have any ideas what may be up with the sodding thing?
 

·
Administrator
Joined
·
20,064 Posts
Poor connection somewhere? Don't throw parts at it....do you have a volt-ohmmeter? Don't have one? go get a cheap one. Harbor Freight in the USA....where are you? not in your profile.

Measure the voltage at the battery terminals. Key off....key on... running.

You should see around 13 volts key off, near same with key on with slight drop, and 14~15 with engine running. That will confirm your battery is good and your charge system is functioning properly.

I would look closely at the main power connector at the starter relay/main fuse first. A common area for connection problems that cause your symptoms.
 
  • Like
Reactions: Digital

·
Registered
Joined
·
100 Posts
Discussion Starter #3
Hopefully it's a poor connection. Got a meter so will check the battery tonight, most likely tomorrow as it's on the tender at mo.

When I had the previous issue with the stator, I got a spare reg/rect. Got an old yuasa too. So I can swap out those parts pretty easily.

Going to test the stator for phase issue. when testing across the connectors any advice? With ignition on?

Also on the starter relay/solenoid what do the B & M stand for?
 

·
Super Moderator
Joined
·
22,486 Posts
Battery and Main
 

·
Super Moderator
Joined
·
22,486 Posts
Do you have the Shop Manual?
 

·
Registered
Joined
·
100 Posts
Discussion Starter #6
yeah got the link for it. Was looking this morning when recovery guy looked at starter relay and was going to attempt to jump from there.
But both wires were +ve. Just noticed a 'B' and an 'M'.

Thought i'd ask the question. Thank you muchly.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #7
Not battery as it accepts and recharges.

Not ref/rect

Stator. The second bloody one...
 

·
Administrator
Joined
·
20,064 Posts
That's unusual..... How did you diagnose it?

And when it came out did it look dark or burned?
Got a photo of the failed stator? I'd like to see its physical appearance.
 

·
Registered
Joined
·
14,532 Posts
?

In the manual there will be a stator test......
Unplug the stator from the harness, there will be 3 wires usually yellow
The manual will give a test RPM usually 4,000 and a voltage
Set your meter to AC volts
Test the pairs 1-2, 1-3 and 2-3
Also check the 3 wires for continuity to ground (the core)

This BULLSHIT started ~2000 with ND alternators, the rotors had too much
magnetism.....You need ~1,300 Gausses to make 500 watts so they tell me
My '04 Aprilia RSVR reads 2,600:wink2: you can thermal image the stator THROUGH THE CASES
From the color of the stator core, it was hitting ~530° F

Stop complaining, my Aprilia RSVR had 7 stators>:)
 

·
Premium Member
Joined
·
2,897 Posts
Was your bike ever pressure washed? Did you buy it new?
 

·
Registered
Joined
·
1,868 Posts
Hi Digital, I was having electrical gremlins on 6 bikes European and Japanese brands and the problem ended up being bad batteries in all 6 bikes. You can take your battery to AUTOZONE ect and they can test your battery to see if cells are charged evenly. . I have been purchasing my batteries from batterystuff.com for years. Lightning fast free shipping and competitive prices . BUT now the SCORPION brand batteries they sell, which have been fine in the past are now crap. Normal battery charger says full charge but SCORPION batteries have been having UNEVEN cell voltage and this screws up the computers . YUASA Batteries from now on. Montgomeryville cycle center is a brick and morter dealer.Which I prefer to buy from, they have fast online shipping, and carry YUASA brand batteries .
 

·
Registered
Joined
·
100 Posts
Discussion Starter #12
The battery charges fine, its been on a tender from dead and then it ran run for approximately 30 miles. i.e. how far you can get on a full charge.
 

·
Registered
Joined
·
1,868 Posts
Digital I just had battery on tender said full charge but the cells where charged uneven. I am suggesting having battery checked by Autozone ect if you cant find problem.. ALSO check voltage of battery with volt meter. Many times I have seen batteries that a tender will show full and battery has only 11 volts . I have 10 bikes in my garage all on tenders . Newer bikes computers are very touchy when it comes to voltage .
 

·
Registered
Joined
·
14,532 Posts
?

Digital;
Check all your electrical connections
The problem is usually between the Stator and the R&R, but also check the connectors between the
R&R and the battery

Alternative sources of stators.....
Rick's Motorsport Electrics in New Hampshire 800-521-0277
ElectroSport in Escondido CA 760-842-8300

Most bikes with stators use the same one......but the 3 wires may be longer and the plug different
 
1 - 14 of 14 Posts
Top