MV Agusta Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Automotive tire Motor vehicle Automotive exterior Bumper Vehicle


so after a dealer visit to get bike on Faultcode and diagnostics it has given back error
CAN LINE : No comms between the engine module and yaw rate sensor missing signal U1706
I think it’s this sensor under left front cover so wondering does anyone know where I could get a replacement one to try fix this issue ? It’s an ACTIVE status
 

·
Old Wing Nut
Joined
·
24,885 Posts
Probably from your MV dealer is the best bet. But google search for the company that makes it might yield some other directions. Perhaps a bike breaker and eBay? I believe that same sensor is used on pretty much every newer MV.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Probably from your MV dealer is the best bet. But google search for the company that makes it might yield some other directions. Perhaps a bike breaker and eBay? I believe that same sensor is used on pretty much every newer MV.
Excuse my ignorance - bike breaker ?
 

·
Old Wing Nut
Joined
·
24,885 Posts
Excuse my ignorance - bike breaker ?
People who buy damaged or crashed bikes, disassemble and sell the parts.

We once had a valued member here who had a business doing that with MV Agustas.....he was a great global source of parts. Unfortunately, he tired of the business and started another. I believe he still has a large stash of first generation MV parts in his storage.
 
1 - 4 of 4 Posts
Top