MV Agusta Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi , I am in need of help , no MV dealer here in Darwin and my F4 is experiencing engine performance issues , wont rev , hard to start , stalls easily. Fuel filter replaced , injectors tested , fuel lines replaced , spark plugs checked / cleaned air filter replaced . Bike struggles to reach 100 kmh ... Any ideas out there on what I could try next ?? Has anyone ever checked fuel pressure on one of these bikes ? Any help would be appreciated. Thanks .. Greg
 

·
Registered
Joined
·
2,087 Posts
Hi , I am in need of help , no MV dealer here in Darwin and my F4 is experiencing engine performance issues , wont rev , hard to start , stalls easily. Fuel filter replaced , injectors tested , fuel lines replaced , spark plugs checked / cleaned air filter replaced . Bike struggles to reach 100 kmh ... Any ideas out there on what I could try next ?? Has anyone ever checked fuel pressure on one of these bikes ? Any help would be appreciated. Thanks .. Greg

Hey bud worth checking ypur ECU. How long have you hsd it? I remember hdving to chsnge my ecu on my SPR not long ago it has 30k km


Sent from Motorcycle.com App
 

·
Super Moderator
Joined
·
22,070 Posts
Hi Greg. The usual question mate, did you replace fuel fittings, are the opening properly ? Have you fiddled with your TPS ? Go through the motions and reset your TPS.
 

·
Administrator
Joined
·
19,553 Posts
Fuel line quick connects can restrict fuel supply if not proper type. New fuel lines? what connectors did you use??
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Hi , bike has basically sat in shed since I have had it , travelled only 1500 kms , but still may be the problem ..
 

·
Super Moderator
Joined
·
22,070 Posts
Wow, stood a long time, sounds like it had fuel in it also. Did you check the fuel pump strainer when you did fuel filter ? How did you get the injectors checked ? Replaced spark plugs ?
 

·
Registered
Joined
·
13,695 Posts
Those are the exact same symptoms I had with my SPR track bike.

I really, really, hope you don't have the same problem.

Based upon the amount of time the bike has sat, I'm guessing problem is in the fuel delivery system.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
Cag , thanks for your post , if it sounds familiar symptoms , can you advise me what you found in the end to rectify it ? I have been right through the fuel system and nothing has changed. cheers
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
DONSY , thanks for your reply , Yes I had fuel in it , injectors were checked at one of the fuel injection shops here , and tested ok . Spark plugs cleaned up and checked , look fine.have cleaned the fuel system right out and ran an additive and new fuel but no improvement.
 

·
Super Moderator
Joined
·
22,070 Posts
Sounds good Greg, there's a strainer under the fuel pump which might be blocked. Did you fiddle with the TPS at all ? (Throttle position sensor at the r/h side of your throttle bodies).
When the bike runs, does all 4 cylinders fire ?
Sorry about all the questions, it's a bit hard to do this on-line.
 

·
Registered
Joined
·
13,695 Posts
Bent valves, my friend. Not bent enough that you could tell by looking at them in the head either. If you want to explore this further give me a call. It was just the valves. The head was fine.
 

·
Super Moderator
Joined
·
22,070 Posts
Bent valves, my friend. Not bent enough that you could tell by looking at them in the head either. If you want to explore this further give me a call. It was just the valves. The head was fine.
Did you ever figure out how those valves got like that in the first place Carl ?
 

·
Registered
Joined
·
14,420 Posts
100kph SPR?

cut to the chase;

fuel restriction, disconnects, filter
fuel pressure, bad fuel pressure regulator, loose line in tank
measure engine cranking pressure.......Carl's problem, bent valves:jsm:
 

·
Registered
Joined
·
13,695 Posts
I guess it was over revved, Dons. I still have the head with the non bent valves still in it.
 

·
Registered
Joined
·
14,420 Posts
Did you ever figure out how those valves got like that in the first place Carl ?
cut to the chase;

Carl's problem, bent valves:jsm:
I guess it was over revved, Dons. I still have the head with the non bent valves still in it.
somebody missed a shift more than likely......or double down shifted......and scared the fuck out of themselves :jsm::jsm::jsm:
 
1 - 20 of 23 Posts
Top