MV Agusta Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter #1
Hi all!

My F4 750 is draining out the power of my battery. First I blaimed myself for not maintain the battery during snowy season but when I put another battery in (fully loaded) it was empty a wheek later. I have no alarm or such on the bike so the electric is standard...

any thoughts?

cheers, zeta
 

·
Registered
Joined
·
6,448 Posts
JamesC said:
Common. Keep it on a maint charger in my experience.

Yep; I agree
 

·
Registered
Joined
·
2,156 Posts
check the alternator and regulator. Use a multimeter to see if the battery is being charge. The manual should tell you what the charging voltage is when the bike is running.

Return the new battery and get another one, I've seen new battery as DOA out of the box.
 

·
Registered
Joined
·
170 Posts
Discussion Starter #6
Thanx for all help...

I did test if the battery gets charger while the engine is running and the voltage increased from 12,4 to 14,5 so that would prove it's being charge or?

I'm getting a new battery today so I'll test that.. I usually maint charge during snowy season but this year I moved between houses and missed that part. The battery is a sealed racing battery (Red Top) that should work even if it's not maint charged. My dealer is lookin in to that.

The charge fuse I couldn't really understand how to check them but since it looks like it's chrging the battery maybee I don't need to?

cheers, zeta
 

·
Registered
Joined
·
1,049 Posts
I had similar problem. Since I use my bike once a week on average my dealer suggested I fit a trickle charger to the battery, which I have done and keep it charging. Works a treat, no more hassles.
 

·
Registered
Joined
·
170 Posts
Discussion Starter #8
Greg Albert said:
I had similar problem. Since I use my bike once a week on average my dealer suggested I fit a trickle charger to the battery, which I have done and keep it charging. Works a treat, no more hassles.
I sure will, thanx!

cheers, zeta
 

·
Registered
Joined
·
1,937 Posts
hb88xx said:
Would not say so, even with alarm mine kept enough to start after two months. Have a charger now for keeping the battery in better shape during lifetime.

As of today I have averaged 821mi/1321km per month since I bought the F4 39 months ago. I am on my 3rd battery. I have learned to use a charger even with that much use. The batteries last much longer, again in my experience.
 

·
Registered
Joined
·
225 Posts
JamesC said:
As of today I have averaged 821mi/1321km per month since I bought the F4 39 months ago. I am on my 3rd battery. I have learned to use a charger even with that much use. The batteries last much longer, again in my experience.
yep I've got to charge up the battery every couple of days as my datatool alarm drains the battery pretty quickly. My wife has reckons that the MV must stand for "mains voltage" as it always seems to be attached to the charger!!! :loser: :) :conveyer:
 
1 - 13 of 13 Posts
Top