MV Agusta Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1
Hello... I ´m looking for help again.

After engine rebuilt i was happy... i was....

Today i went out to drive some miles. I was cruising (6k rpm) when fuel light went on. I drove to a gas station and refilled the tank.

After that my engine does not revs at all.

In first gear she reachs limiter; In second, around 11k; in third, 9.5k, in fourth, 8k and 5º and 6º no more than 7k.

In neutral engine is a hurricane.

I changed (i bought like spare part) EBS: nothing.

I checked fuel lines: Not leak (i have metal male ones)

I changed eprom for another one: Same problem.

I checked tank air breather: i put some pressurized air and by the external hose went of some carbón parts ...?? It´s ok?

engine sounds good (i ´m very afraid after a rebuild)

Sparks are NGK Iridium (not more than 2k miles). I repeat in neutral..no problems.

It´s sames fuel problem...maybe fuel pump... I don´t know where to look.

I will apreciate any help.

Kind regards.



Fernando
 

·
Super Moderator
Joined
·
22,504 Posts
It does sound like fuel starvation. Did you have the tank off?
Check for pinched fuel delivery lines.
Check the tank vent is unrestricted. (Simple check: Run engine with tank lid open.)
I'd be tempted to check the fuel pump and filter.
It could be a simple as a bad fuel load.
 

·
Vendor
Joined
·
5,373 Posts
Could be internal fuel hoses perished in the tank.Are they new?Has your bike got the evap canister?It could be falling apart internally.Seen that before.Just thinking.
 

·
Registered
Joined
·
5,580 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #5
Difficult to probe.. I must get at least 160Kmph.
I will get the tank put and check every conncetion. Lines are new. I changed about a year ago. Looking with a lintern a i see pump by pass shooting fuel to the top of the tank.. so pump is working properly a has good pressure. Hoses to the filters could be watched and there is no leak.
Maybe one of female conncectors is wrong and does not opens completly...
I´m worried because i come from a rebuild and now everything gives me pain...
Sames like bad fuel loading..but...

Thanks for replies
 

·
Registered
Joined
·
14,534 Posts
Fernando;
is the fuel spraying to the top of the tank coming from the top of the fuel pump?

because the return line sprays to the side.....is the 90 degree fuel line elbow visible?

MV2envy just had a bad fuel pump it was coming out the top
 

·
Administrator
Joined
·
20,104 Posts
Or could be as simple as the fuel filter has finished doing its job.....an inexpensive part that can give exactly same results you are having.....cannot flow enough to supply demand under higher loads.

That is my guess. Take the tank off and check the connectors for full flow, and replace the filter.

Do you get ethanol polluted gasoline? Ethanol and water combine to create a nice sludge that clogs filters.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #9
Difficult to see from where fuel comes. I will dissambly every connection and check again. I am sure that my problem is less fuel that i need... but i must understand where is the fault.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #10
Fuel filter is new. But it could be. Maybe i should change it too. Thanks for the response. I will mantain informated.
 

·
Registered
Joined
·
5,824 Posts
Change the fuel filter, make sure it's installed in correct orientation. The arrow I. The fuel filter should be pointing down. And do a evap system delete. And make sure you don't pinch any fuel hoses when putting the tank back on. While you are in there, put a new fuel pump in. $30 on ebay.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #14
Very happy. Problem solved. Were quick connectors... they restricted fuel quantity. Now she goes like hell. Thanks to all of you and for Alex of gutsy perfomance.
 

·
Registered
Joined
·
5,580 Posts
Great!! Have fun!
 
1 - 16 of 16 Posts
Top