MV Agusta Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
535 Posts
Discussion Starter #1
I noticed this a while ago. The gear indicated on the dash would switch back and forth between gears even though I wasn't shifting. I originally thought it was because I did some quick down shifting or something (at the track) and the bike was still trying to register the proper gear. Anyways I went on a subtle street ride to where I could actually pay attention to the dash. If I was maintenance or slightly on the throttle it would display back and forth between 2 gears. From closed to wide open throttle the display behavior changed from completely wrong to accurate. Makes me think it's an electrical or connection issue. Anyone else had this issue?
 

·
Registered
Joined
·
1,511 Posts
One of the most common faults, warranty issue, your dealer should be aware, contact them.
 

·
Registered
Joined
·
265 Posts
I noticed this a while ago. The gear indicated on the dash would switch back and forth between gears even though I wasn't shifting. I originally thought it was because I did some quick down shifting or something (at the track) and the bike was still trying to register the proper gear. Anyways I went on a subtle street ride to where I could actually pay attention to the dash. If I was maintenance or slightly on the throttle it would display back and forth between 2 gears. From closed to wide open throttle the display behavior changed from completely wrong to accurate. Makes me think it's an electrical or connection issue. Anyone else had this issue?
Sensor should be replaced under warranty. Completely new design.
 

Attachments

·
Registered
Joined
·
42 Posts
I'm having similar problems with my F3 675. I've hit a false neutral between 4th and 5th gear while quickshifting (gulp). Since then occasionally my green neutral light comes up on the screen when shifting between 4th and 5th even when it is in 5th gear. Last time this was followed by the orange "engine malfunction" light going on. I slowed down ready to stop the bike but it turned off again about a minute later.

And my bike is no longer under warranty.
 

·
Registered
Joined
·
465 Posts
Have a chat with your local dealer and see if they can source and fit you one of the new units for a reasonable fee.

Mine was replaced under warranty, it used to be fine until 4th then it could be in 4-6 depending on what mood it was in. New one is totally new and works really well.
 

·
Registered
Joined
·
535 Posts
Discussion Starter #6
Thanks you guys. I just moved not long ago and the closest dealer is about 2 hours away now. It was just at the dealer for a couple of months before I moved to fix sprag clutch, rear brake, and throttle housing. I had completely forgot about the gear thing. I'll call and see if they can just send me the sensor under warranty without diagnostics
 

·
Registered
Joined
·
95 Posts
I just picked up my 2013 B3 800 today (private sale) and on the 250km ride home I noticed 6th wasn't showing although I definitely was in 6th.
My bike is out of warranty so any idea of the replacement part cost? I could live with it until the 12000km service. At least I now know it's nothing major.
 

·
Super Moderator
Joined
·
22,072 Posts

·
Super Moderator
Joined
·
22,072 Posts
Yeah I can't remember too well, but I though it was a recall item, I might be wrong and the other guys on here might know better. Enjoy the ride mate. Download manuals from my site too, always handy.
 

·
Registered
Joined
·
138 Posts
I was reading about how you test that thing in the shop manual only two days ago. It works off resistance just like an ohm meter, maybe you just have some poor connections, maybe a part really is toast. Either way it ooked like it was pretty easy to test.
 

·
Registered
Joined
·
535 Posts
Discussion Starter #13
They sent me the kit for free since there's no local support. Relatively easy to install. They do add a piece to the wire harness that runs back to the diagnostic plug which was probably the worst part.
 

·
Registered
Joined
·
320 Posts
I have the same issue on my 2012 F3 675, just had a look on Star twin and I am a little confused....



My Vin is: ZCGF310AACV001596 so I am going to require one of the first 2 lines... my question is do I need the gear switch kit or just the gear sensor?
 

·
Registered
Joined
·
320 Posts
Tasty.. You shouldn't have to buy the kit; it's a service bulletin item. But it's 8970 that you'll need.
Thanks, I'm going to give MV Australia and see if there is anything they can do for me, surely they can see by the VIN that the sensor hasn't been changes.

If they can't/wont help me I'll order the 8000B8970 from Star Twin
 
1 - 17 of 17 Posts
Top