MV Agusta Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi everybody,

I've been following this forum for quit a while and are impressed by the level of technical experience some of the memebers have.

I hope I can get some advise fom these members.

I changed the eprom of my 910S today to have the full horse power (restricted to 100 HP in France). I did everything as descripted in the technical hand book, but surprise, the engine doesn't start after the eprom change. Everything seems to be normal (noise if the fuel pump and lights), but no engine.

I remember somebody else had a similar problem and he got a lot of advise, but I can't find the thread.

I hope somebody can help, because the local dealer is really useless.

Thanks
 

·
Registered
Joined
·
350 Posts
1st make shur the eprom is pluged in all the way down. If that doesent work make shur you didnt bend any of the prongs. If that doesent work try the original eprom. Let us know after you check those things.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
I did exactly as you suggested and finally gave up and installed the original EPROM. The engine fired up with a single push on the button. I guess something is wrong with the EPROM. Btw, it's no rocket science to change the EPROM.

Thanks for your help.
 

·
Registered
Joined
·
2,388 Posts
I have read that it is easy to plug it in backwards.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
The EPROM has a notch and the socket as well. I recommend to use an EPROM puller to get it out and just be careful when you plug the new EPROM in.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
I had big problems to get the "open/full power" eprom at all. My dealer was unabler to supply it (aslo it was part of the deal, imagine driving your Brutale handicaped with 100 HP only).

So he guys from emoto UK finally got me the eprom. I guess something went wrong with the programming or it got some electrostatic during the shipment.

I can't wait to find out how the bike does with all her horesepower. Allready did 2000 miles like this and have the feeling something holds me back at high reps.

I had an open 750 before which had less torque, but more power at the high end.

If anybody has a good source for an eprom I would appreciate this. I don't want the PC III because I don't have a dealer nearby who can program it.
 
1 - 8 of 8 Posts
Top