MV Agusta Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
971 Posts
Discussion Starter #1
People,

My F4 2000 model has just been rolled out for the summer here in the UK.

Whenever the engine is either on or off, the throttle twist grip opens nicely and returns back with a sharp snap that to me says there is no noticeable cable resistance.

However, when riding sometimes when easing off the throttle the engine doesn't want to slow down very quickly (as if I still have the throttle partly open).

Does anyone have any ideas what maybe causing this and how I rectify it?

Cheers




Submariner
 

·
Registered
Joined
·
1,216 Posts
If you apply pressure to close it does it then return to a proper idle? I had that problem when my cables needed adjustment. (I mean when I adjusted them and screwed it up..)

Si
 

·
Registered
Joined
·
520 Posts
Yep the hand grip rubber fouled the bar end on mine a couple of times. Most disconcerting at the time!


Sent from Motorcycle.com App
 

·
Registered
Joined
·
971 Posts
Discussion Starter #8
cheers guys I am going to look at the weekend. i don't think the grip is sticking to the bar end. I have just recently adjusted the throttle screws with the sliding rod type arrangements so maybe that has done it
 

·
Registered
Joined
·
935 Posts
How long was it stored? gummed fuel may Partially clog stuff making for a lean condition. Lean condition can cause the idle to "hang" before returning to normal.
 

·
Super Moderator
Joined
·
22,070 Posts
cheers guys I am going to look at the weekend. i don't think the grip is sticking to the bar end. I have just recently adjusted the throttle screws with the sliding rod type arrangements so maybe that has done it
I think you answered your own question right there.
 
1 - 10 of 10 Posts
Top