MV Agusta Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
652 Posts
Discussion Starter #1 (Edited)
For some reason this post isn't being displayed correctly on the mobile version of MO? Refer to the browser posting

Last couple of rides I've experienced significant engine roughness/hesitation at low revs <4.5K, comes in when bike is at full operational temp. Runs fine above this rev range.Bike is 3K past 24K service so thinking things like plugs etc should be fine.Any hints to what it might be?
 

·
Registered
Joined
·
1,659 Posts
I would suggest a couple of options Steve.
For a cheap one try running a can of fuel injection cleaner through the system. I have used LiquiMoly from Supercheap as it is labelled as safe for cats. Give it a good thrashing at high revs and full throttle in an appropriate area.
Seeing as you are due for service, I would suggest getting booked in with Ozracing as he uses Axone for diagnostic software, which is very comprehensive. He can see pretty quickly if anything is out of wack. It could be as simple as plugs starting to break down under load.
 

·
Vendor
Joined
·
5,281 Posts
Steve,dig out the service invoice,did they charge you for spark plugs?
 

·
Formerly - dagmvagusta
Joined
·
423 Posts
Sounds like mapping to me. If your still running the stock Ecu you may need an update. If no update is needed I was suggest a fuel management system like Bazzaz (what I have on my 2012 f4r) PC v or microtec. Have a tuner build you a custom map and you will see a world of difference throughout the rpm range smooth as silk. Especially if the turner is good and knows what he is doing.


Sent from Motorcycle.com App
 

·
Registered
Joined
·
652 Posts
Discussion Starter #7
I would suggest a couple of options Steve.
For a cheap one try running a can of fuel injection cleaner through the system. I have used LiquiMoly from Supercheap as it is labelled as safe for cats. Give it a good thrashing at high revs and full throttle in an appropriate area.
Seeing as you are due for service, I would suggest getting booked in with Ozracing as he uses Axone for diagnostic software, which is very comprehensive. He can see pretty quickly if anything is out of wack. It could be as simple as plugs starting to break down under load.

Hi Jon - going into the shop for a checkout next week - if no satisfaction will try ozracing.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
652 Posts
Discussion Starter #9
Well I'm stumped - threatened the bike by taking a trip into the workshop today and it's decided to lose all engine hesitation issues previously described :-/
Shall take it for a jolly good flogging this afternoon to double check - hopefully it isn't one of those randomly occurring issues.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
652 Posts
Discussion Starter #10
Ok - so took it for a ride up some twisties - low and higher revs - performed flawlessly.
Until... After riding another 30 odd km - stopped at lights for a couple of minutes and it started to idle a bit rough. Didn't seem to run on all four when pulling away and ran rough until I got home a couple of km later.
Really puzzling
NB had stopped at a couple of intersections during early part of ride but no rough idling issues then. Had fuelled 1/3 way thru trip but can't see this having affected anything given problem didn't show for at lead another 60km.

Wtf?


Sent from Motorcycle.com Free App
 

·
Vendor
Joined
·
5,281 Posts
Steve,you are out of warranty arn't you.What cost are the coils?They may be available aftermarket.
 

·
Registered
Joined
·
652 Posts
Discussion Starter #17
Steve,you are out of warranty arn't you.What cost are the coils?They may be available aftermarket.

Yes - but haven't had much post warranty time on the bike - partly due to the problem. The shop and MV Australia are apparently doing as much as they can to get a good outcome but the factory is being a bit slow to respond. PM'd you the other detail.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
30 Posts
Renaissance,

Do you recall how hot the bike got ? This issue 1st happened to me a few months ago. I thought the issue was attributed to hot day but then fuel. I wasn't out...low light wasn't even on...but I decided to add some fuel and she started right back up so thought bad fuel. I later even checked hoses for kinks...

Then it happened intermittently a couple other times (I recall on hot days). So after playing her reindeer games a couple times, I was thinking something with the fuel level/pressure in the tank because I always add fuel and she starts back up and runs. Was hoping to make it to winter and then look into it but then happened last week 2 days in a row. 1st day I added fuel and as normal back onto the streets...2nd day when it happened, I somehow broke the overflow line in the tank and she pissed at the station so had to get her home on the truck and fix that 1st...but after resolving and getting her back together...she still wont go. Seems to be the same...1st start has rough idle, then warm, she smooths out...I can rev to redline (13.5k) but when in gear...no power over 4.5K and worse SHE WON'T TAKEOFF :( ! ! Its almost like if I give too much throttle...she bogs down and wants to cut off...gonna try looking at the coils tomorrow or this weekend.

I asked about how hot it runs when it happens because even though bike never reported to over heat, it did seem to run hot (couple bars from top) but never reached top. Also issue never happened to me at night (no Vegas sun beating down).

I think the heat "worsens" the issue until no longer ridable ?

FYI...A gallon of water is alot to drink when all u wanna do is get back on and ride ! !
 

·
Registered
Joined
·
652 Posts
Discussion Starter #19 (Edited)
Renaissance,

Do you recall how hot the bike got ? This issue 1st happened to me a few months ago. I thought the issue was attributed to hot day but then fuel. I wasn't out...low light wasn't even on...but I decided to add some fuel and she started right back up so thought bad fuel. I later even checked hoses for kinks...

Then it happened intermittently a couple other times (I recall on hot days). So after playing her reindeer games a couple times, I was thinking something with the fuel level/pressure in the tank because I always add fuel and she starts back up and runs. Was hoping to make it to winter and then look into it but then happened last week 2 days in a row. 1st day I added fuel and as normal back onto the streets...2nd day when it happened, I somehow broke the overflow line in the tank and she pissed at the station so had to get her home on the truck and fix that 1st...but after resolving and getting her back together...she still wont go. Seems to be the same...1st start has rough idle, then warm, she smooths out...I can rev to redline (13.5k) but when in gear...no power over 4.5K and worse SHE WON'T TAKEOFF :( ! ! Its almost like if I give too much throttle...she bogs down and wants to cut off...gonna try looking at the coils tomorrow or this weekend.

I asked about how hot it runs when it happens because even though bike never reported to over heat, it did seem to run hot (couple bars from top) but never reached top. Also issue never happened to me at night (no Vegas sun beating down).

I think the heat "worsens" the issue until no longer ridable ?

FYI...A gallon of water is alot to drink when all u wanna do is get back on and ride ! !

Enough to cough up some of it's coolant initially - maybe 500ml. Haven't had a problem with that since replacing the fuse and refilling with coolant (with no problems with air bubbles if you take your time and use the air bleed screw on the transfer elbow located on the LH of the engine block)

Not clear to me you have the same problem as me (coils). By the way my engine hesitation occurred prior and post the time it blew the fan fuse.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
568 Posts
Sounds like mapping to me. If your still running the stock Ecu you may need an update. If no update is needed I was suggest a fuel management system like Bazzaz (what I have on my 2012 f4r) PC v or microtec. Have a tuner build you a custom map and you will see a world of difference throughout the rpm range smooth as silk. Especially if the turner is good and knows what he is doing.


Sent from Motorcycle.com App
Is there a Microtec for the post 2010 bikes?
 
1 - 20 of 21 Posts
Top