MV Agusta Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
I am trying to resolve a nasty little backfire issue with my 2005 F4 Ago. The bike has the RG3's and the revised chip installed. On decel the bike has tendancy to backfire (pop loud) through the exhaust. The midpipe on the bike has the bulge where the cat should be. My question is, does the AGO have a cat? I have called Cagiva, Ferracci, Munroe Motors, you know all over. Some say it has a cat and some say it doesn't. If it does I think it might be contributing to my backfire problem (any other suggestions are welcome). The bike has had the TB's check and the chip has been massaged. If it does have a cat I am planning on buying the Ti midpipe for the bike. Best I can gather from the MV site is that the bike only came with the RG3 pipes and the chip, no midpipe. Does anyone have an answer based on fact? Thank you for your time.
 

·
Registered
Joined
·
604 Posts
nick, welcome. My bike is in the shop and it was acting that way as well. I will post up what they tell me tomorrow and maybe that will help you out. Also, my bike was shooting out flames.
 

·
Registered
Joined
·
1,285 Posts
The AGO came with cat, but if pipes and chip were replaced it does NOT have a cat currently.

Backfiring may be bad gas or running rich. Once you start messing with these machines, they need to be tweeked periodically. Some of the guys here know what to do about it and I'm sure will chime in.


DD, shooting flames means it's running real rich, and it sounds like it is at the right place.

Peter
 

·
Registered
Joined
·
1,292 Posts
Reopropf said:
Backfiring may be bad gas or running rich.
DD, shooting flames means it's running real rich, and it sounds like it is at the right place.
Peter
Class.....
We need to differentiate between backfiring and decel popping.

Backfiring is the build up of gas in the exhaust system that will ignite at random times and sound like a shotgun going off.(you WILL know when this happens) :eek:

Decell popping is caused by a lean condition and sounds like small backfires but happens very consistantly. More like a rumble popping sound.
When a bike runs lean, some gasses are not burned completely and when they hit either the hot exhaust system (lean runs hot) or fresh air at the end of the tailpipe they will self ignite. This is probably the flames you are seeing.

So, is this a random shotgun going off every once in awhile, or a more constant smaller popping noise??

Class dismissed! :nerd:

John T
 

·
Registered
Joined
·
38 Posts
Discussion Starter #6
The bike does not make small pops but one loud pop. From what MV shows on their website it only has a picture of the RG3's and a chip, no midpipe. I take this to mean that you use the stock midpipe which has a cat in it. I guess i will pull the pipe apart tonight and take a look. I know for sure the Tambo has a Ti midpipe included with the bike, it list it on the MV site and I have seen it in person. DD, please let me know what you find out. Thank you for all the replies.
 

·
Registered
Joined
·
1,285 Posts

·
MV Cellist
Joined
·
4,595 Posts

·
Registered
Joined
·
1,536 Posts
MY 2005 Ago, bought new came with....

IN a box...
RG3 slip ons
Mid pipe with bulge, but NO Cat....you can look inside an see the abscense of the honey comb catalyzer. More or less a stock mid pipe in which the catalyzer was not installed.
Plus a Replacement EPROm.

Per the instructions from my dealer (atlanta truimph ducati) they told me not to install the eprom as the mapping was not beneficial. Ferracci confirmed this when I called them. They said I could put the Rg3s on, but leave the cat mid pipe in place unless I go to a Power commander. Seemed to run fine but there was still a flat spot down low.

I installed a PC and replaced the midpipe with a MVSP Ti midpipe (smooth the entire length with no bulge to upset flow) had the PC mapped and the flat spot was fixed. Some decel popping, but no backfireing. I think part of the decel popping is due to the EBS.

I anticipate the next question to be .....how much Hp did it make...

Well, I was a little disappointed. It was a really hot day with intake temp above 95 degrees. My dyno guy said that the dyno corrected for altitude, but not the ambient temp. (i dont know for sure if that is entirely correct)
154 hp and 77lb torque.
anyways....I know I have never been pulled by any zx-10 or k5 on the street or track coming out of a corner or down a straight......now the corners,.....no comment
 

·
MV Cellist
Joined
·
4,595 Posts
Reopropf said:
That farting stuff is just plain funny; can't but laugh at it!
yes... :laughing: :laughing: Now doctor, please clear the myth and tell us if that(lighting the fart) is potentially dangerous... in an explosive way.

BTW Sorry for hijacking the thread...
 
1 - 12 of 12 Posts
Top