MV Agusta Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
FNG here. I'm the lucky SOB that purchased ks9mm's 910S. Have ridden 800 miles so far. The bikes running great & I'm gaining more confidence each time out.

My problem is the right directional. It blinks as it should, but it won't turn off?
Left one is fine. Fuse is ok obviously as it is blinking. Did the switch go bad?

All answers from the esteemed group are welcome.

Thx!
G
 

·
Registered
Joined
·
572 Posts
so, you're saying you put the blinker in the right turn position and it just blinks away forever?
 

·
Registered
Joined
·
102 Posts
Discussion Starter #4
That's right. I put the right directional on, it blinks & won't turn off? The left one works as it should.
 

·
Administrator
Joined
·
20,056 Posts
Most likely soemthing as simple as contamination/corrosion inside switch preventing off selection when button is pushed. Remove and clean.
 

·
Registered
Joined
·
572 Posts
yeah, give it a cleaning. Blinker assemblies aren't that complex unless the Italians have gotten really creative and fixed a weasel to the inside of the blinker switch or something. If that doesn't do it, see if it's under warranty. Otherwise, there was some guy on an eBay store who stripped a brute and an f4 for parts.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #7
I removed the instrument panel cover & cleaned out the connector. Still same problem. Dealer says he thinks the switch just went bad. It under wty still, so I'll have them take a look.

Thx for the feedback!
 

·
Registered
Joined
·
312 Posts
put some LED blinkers, much more visible and looks 10 times more neat
 

·
Registered
Joined
·
572 Posts
yeah, but don't get those crummy tiny blinkers, I can never see those in the daylight.
 
1 - 9 of 9 Posts
Top