MV Agusta Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
I've been trying to get cruise control to engage using either the lhs toggle and select button or the rhs cruise button but I've not managed to get it to engage.
Using LHS button I can toggle to the dash cruise menu and then holding the button in to select doesn't work nor does pushing or holding the rhs cruise button, I've tried this at various speeds (over the lower limit documented on user manual) and not had any success. Am I doing it wrong?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
Probably not, as I was trying this at speeds between 30 and 50mph (and trying not to crash when watching dash not engage cruise) so was probably in a lower gear . Will try it in 6th next time i'm on the bike (hopefully tomorrow)
 

·
Registered
Joined
·
36 Posts
Discussion Starter #5
Cheers all tried today and it works so definitely need to be in sixth gear, seem to have missed that in the manual.
 

·
Registered
Joined
·
1,630 Posts
If you're finding it won't engage, granted the OP has now found out why his isn't, it could be that either your clutch switch, quick-shifter or gear position sensor are playing up.

I'm currently waiting for a replacement QS sensor and found that the cruise control will only work if I switch off the QS from the dash settings menu. With QS turned on I get an error message stating that cruise control cannot engage on my dash.

Gear change detection, amongst other metrics, are obviously used in the cruise control cancelling system and, sensibly, if one of these sensors is in an abnormal state then it is inhibited from engaging.

Oddly I have no error message that my QS sensor is borked.
 
  • Like
Reactions: JerseyBrut

·
Registered
Joined
·
500 Posts
I love the cruise configuration on the MV because you can set the speed by number given on the dash, and it is not just an up or down button you hold for an approximate time. If you want to travel at 74, the screen looks like (73 74 75) and you shift right or left.
 

·
Registered
Joined
·
5 Posts
My cruise control used to be working but since i off off my qs, change my tc from 1 to 6 it doesnt work anymore.. when press the lhs button, it just indicate cruise control is off.. is it anything to do with the qs or tc?

Sent from my BV5000 using Tapatalk
 

·
Registered
Joined
·
1,630 Posts
My cruise control used to be working but since i off off my qs, change my tc from 1 to 6 it doesnt work anymore.. when press the lhs button, it just indicate cruise control is off.. is it anything to do with the qs or tc?
Not quite sure what you mean by "i off off my qs"? If your quick shifter isn't working then cruise control won't work either so long as the QS is still enabled via the dash menus. That's my experience with my TV anyway. Waiting for a new QS sensor from Italy, have been since mid June...

If I disable the QS via the dash menus then cruise works again. Not that I do many freeway/motorway miles so it's something of a non issue for me.

Not sure if the cruise control uses the QS sensor to detect a gear change (and disengage), ergo if it's detected as malfunctioning it will disable cruise control as a safety interlock?
 

·
Registered
Joined
·
431 Posts
Not sure if the cruise control uses the QS sensor to detect a gear change (and disengage), ergo if it's detected as malfunctioning it will disable cruise control as a safety interlock?

Can't change gear with cruise control on Chas, as you know it only works in 6th gear and throttle needs to be in the shut position to change down.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
431 Posts
My cruise control used to be working but since i off off my qs, change my tc from 1 to 6 it doesnt work anymore.. when press the lhs button, it just indicate cruise control is off.. is it anything to do with the qs or tc?

Sent from my BV5000 using Tapatalk


When you press the lhs button try pressing it again, 1 press to get into the CC menu 1 press to activate desired speed? The toggle left or right to fine tune your speed.
I think, Maybe, been a while since I used it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,630 Posts
Can't change gear with cruise control on Chas, as you know it only works in 6th gear and throttle needs to be in the shut position to change down.
Exactly, like my cars (except cruise works in any gear). You touch brakes or clutch and it disengages. With the TV, as you don't need clutch to change down it would make sense for the gear change to also be in that 'loop'. Try cruise control and then pull in the clutch or touch the brakes...
 

·
Registered
Joined
·
431 Posts
Exactly, like my cars (except cruise works in any gear). You touch brakes or clutch and it disengages. With the TV, as you don't need clutch to change down it would make sense for the gear change to also be in that 'loop'. Try cruise control and then pull in the clutch or touch the brakes...


Aye brakes and clutch to disengage it, gears are redundant until it's disengaged


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,630 Posts
Aye brakes and clutch to disengage it, gears are redundant until it's disengaged
Then why is my cruise control disabled unless I turn off the quick shifter in the menus? My QS sensor is currently not functioning, waiting for a new one.
 

·
Registered
Joined
·
5 Posts
Not quite sure what you mean by "i off off my qs"? If your quick shifter isn't working then cruise control won't work either so long as the QS is still enabled via the dash menus. That's my experience with my TV anyway. Waiting for a new QS sensor from Italy, have been since mid June...

If I disable the QS via the dash menus then cruise works again. Not that I do many freeway/motorway miles so it's something of a non issue for me.

Not sure if the cruise control uses the QS sensor to detect a gear change (and disengage), ergo if it's detected as malfunctioning it will disable cruise control as a safety interlock?
I mean i had disable my QS from the screen setting.. there were some problem with my QS i think. Coz when i enable my QS, my bike start to be jerky on lower speed at lower gear.. the jerky seems like i am short of fuel. I have no longer have the problem after i disable my QS but i cannot activate my cruise control.

Sent from my BV5000 using Tapatalk
 

·
Registered
Joined
·
1,630 Posts
I mean i had disable my QS from the screen setting.. there were some problem with my QS i think. Coz when i enable my QS, my bike start to be jerky on lower speed at lower gear.. the jerky seems like i am short of fuel. I have no longer have the problem after i disable my QS but i cannot activate my cruise control.
Does the QS actually still work when it's enabled? I suppose the QS sensor can go bad in a variety of ways. The signals it sends to the ECU can cut power on an up-shift or blip on a down-shift. If it were intermittently sending an up-shift signal then it night give the symptoms you describe.

I'm convinced that this issues I have with my QS is down to ingress of moisture. Will be using some silicone sealant around the point where the wire enters the sensor once its been replaced.

Is your bike is still in warranty? I suggest that you seek the assistance of your dealer.
 

·
Registered
Joined
·
5 Posts
Does the QS actually still work when it's enabled? I suppose the QS sensor can go bad in a variety of ways. The signals it sends to the ECU can cut power on an up-shift or blip on a down-shift. If it were intermittently sending an up-shift signal then it night give the symptoms you describe.

I'm convinced that this issues I have with my QS is down to ingress of moisture. Will be using some silicone sealant around the point where the wire enters the sensor once its been replaced.

Is your bike is still in warranty? I suggest that you seek the assistance of your dealer.
My QS still working when its enabled but will have the jerky problem. Yes my bike still under warranty. Just monitoring all the issues and to identify where the problems are really from before i send back to my dealer. I had the jerky problems before and had already send to my dealer before and they say its due to my engine gasket which had expand and cause some leakage. But i still face the jerky problems. Been a week since i disabled my QS, my bike was no longer jerky but could not engage my cruise control. So i was just thinking wether its related to the QS

Sent from my BV5000 using Tapatalk
 

·
Registered
Joined
·
1,630 Posts
i was just thinking wether its related to the QS
If it's sending a random erroneous up-shift signal then potentially, yes, the QS could be the culprit.

When new my TV had somewhat rough fueling at low speed running, around town was very unpleasant. Mentioned this at the break-in service and Ed Cosker's technician plugged it in and, his words, reset the ECU. A lot better after that and it's also improved significantly as the miles have increased. Maybe a familiarity/acclimatisation thing but I'm convinced that some of this is real rather than perceived.
 
  • Like
Reactions: mva2017
1 - 20 of 34 Posts
Top