MV Agusta Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have been having coolant leakage problems on my F4S but can't seem to locate the exact spot it's coming from. When I brake and the engine is warm there's a small bit of fluid hitting the exhausts. I think it may be from the resevoir but am only able to check by pulling half the bike apart to get it out. Has anyone else had experiences with this sort of problem on this bike?
 

·
Registered
Joined
·
2,351 Posts
If that's the case the hose might have come loose, it should drain out the bottom of the bike.

The common issue I've heard about is the blue mist, where the radiator fails near the mount and sprays coolant when under pressure.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
radiator on 750s

I have been having coolant leakage problems on my F4S but can't seem to locate the exact spot it's coming from. When I brake and the engine is warm there's a small bit of fluid hitting the exhausts. I think it may be from the resevoir but am only able to check by pulling half the bike apart to get it out. Has anyone else had experiences with this sort of problem on this bike?

It seems like it might be a "blue mist" problem where the radiator fails near the hoses. Has anyone else had this problem or something similar and what did you do for it?
 

·
Super Moderator
Joined
·
22,070 Posts
Check for spray near the top L/H side radiator mounting bracket. Not a common problem on the 750's but not impossible I suppose, very common on some later 1000 and 1078 models.
I doubt it would be reservoir as that is under pressure also and if it had a hole in the hose it would piss out full time.
The dadiator moved fwd and bwd's as the bike is ridden. Remove your fairings, start the bike and check it out, you might still be able to fix it with some liquid steel.
 
1 - 5 of 5 Posts
Top